Last Comment Bug 680818 - HAVE_STDCALL is unnecessary on Win64
: HAVE_STDCALL is unnecessary on Win64
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows Vista
: -- normal (vote)
: mozilla9
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
: 680928 (view as bug list)
Depends on:
Blocks: tracking_win64 support-win64 675221 803856
  Show dependency treegraph
 
Reported: 2011-08-21 18:25 PDT by Makoto Kato [:m_kato]
Modified: 2012-10-20 10:20 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.04 KB, patch)
2011-08-21 18:44 PDT, Makoto Kato [:m_kato]
khuey: review+
Details | Diff | Review

Description Makoto Kato [:m_kato] 2011-08-21 18:25:40 PDT
This bustage is by bug 675221.

http://tbpl.allizom.org/php/getParsedLog.php?id=6058097
nsThreadUtils.cpp
c:/mozilla-build/python/python2.6.exe -O e:/builds/moz2_slave/m-cen-w64/build/build/cl.py cl -FonsThreadUtils.obj -c -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrappers  -DOSTYPE=\"WINNT6.1\" -DOSARCH=WINNT -D_USE_ANSI_CPP -DTARGET_XPCOM_ABI=\"x86_64-msvc\" -I/e/builds/moz2_slave/m-cen-w64/build/xpcom/glue/../build  -I/e/builds/moz2_slave/m-cen-w64/build/xpcom/glue -I. -I../../dist/include -I../../dist/include/nsprpub  -Ie:/builds/moz2_slave/m-cen-w64/build/obj-firefox/dist/include/nspr -Ie:/builds/moz2_slave/m-cen-w64/build/obj-firefox/dist/include/nss         -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553  -DNDEBUG -DTRIMMED -Zi -Oy- -Zi -UDEBUG -DNDEBUG -GL -O1 -MT            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT -Zl /e/builds/moz2_slave/m-cen-w64/build/xpcom/glue/nsThreadUtils.cpp
nsThreadUtils.cpp

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsStringAPI.h(1323) : warning C4244: 'argument' : conversion from '__int64' to 'PRUint32', possible loss of data

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsStringAPI.h(1361) : warning C4244: 'argument' : conversion from '__int64' to 'PRUint32', possible loss of data

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsThreadUtils.h(325) : error C2953: 'nsRunnableMethodTraits<R(__cdecl C::* )(void),Owning>' : class template has already been defined

        e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsThreadUtils.h(313) : see declaration of 'nsRunnableMethodTraits<R(__cdecl C::* )(void),Owning>'
Comment 1 Makoto Kato [:m_kato] 2011-08-21 18:44:52 PDT
Created attachment 554781 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2011-08-21 18:59:46 PDT
Comment on attachment 554781 [details] [diff] [review]
fix

This is bustage fix by bug 675221
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-22 09:14:32 PDT
*** Bug 680928 has been marked as a duplicate of this bug. ***
Comment 4 Makoto Kato [:m_kato] 2011-08-22 18:02:31 PDT
http://hg.mozilla.org/mozilla-central/rev/7eb1a56eaaf1

Note You need to log in before you can comment on or make changes to this bug.