Regular subexpressions followed by +, ? not running to completion

VERIFIED FIXED

Status

Rhino
Core
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Phil Schwartau, Assigned: rogerl (gone))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This is the Rhino version of bug 67773 in SpiderMonkey.
Have added this regression testcase to the test suite:


      js/tests/ecma_3/RegExp/regress-67773.js


Note: this depends on a new shell.js file I have added: 


      js/tests/ecma_3/RegExp/shell.js
(Assignee)

Comment 1

17 years ago
Created attachment 27313 [details] [diff] [review]
Fixes converted from 67773.
(Reporter)

Comment 2

17 years ago
With the latest rhino, rhinoi on WinNT, all tests in js/tests/ecma_3/RegExp/ 
are passing. It looks like a fix may have already been posted. See: 


http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&fi
le=NativeRegExp.java&root=/cvsroot&subdir=mozilla/js/rhino/org/mozilla/javascrip
t/regexp&command=DIFF_FRAMESET&rev1=1.31&rev2=1.32
(Assignee)

Comment 3

17 years ago
Sure enough, cool! Since the tests pass I guess you can go ahead and close it 
out. Thanks.
(Reporter)

Comment 4

17 years ago
Resolving as FIXED - 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

17 years ago
And marking Verified - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.