Firefox url bar search slow, because of NBNS queries

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: dfandrew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 554821 [details]
detailed-firefox.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

I'm a bit puzzled, why Firefox is so uber slow with DNS queries. Whenever I type something into the url bar to launch a google search, Chrome finishes under a second, while Firefox twiddling for 3-4 seconds. What the hell I asked and launched Wireshark to debug the problem.


Actual results:

Wireshark showed that when I press enter, it first does 4x LLMNR queries, then 2 or 3 NBNS queries, and finally it makes a GET request for the search term, in this case: "mikkmakk". The problem is around the NBNS queries, which slows down the whole process a LOT. It takes 2 and a half seconds to make the actual google query!

Chrome does 2 LLMNR queries, NO NBNS queries at all and voilá, it finishes under 0.07 seconds. Thats an almost instant result. 

Both browsers were reopened, purged, whatever. So the question is, how can we disable those NBNS queries, to make Firefox actually competitive vs. Chrome.


Expected results:

Give results in an instant, ergo leave out NBNS queries.
(Reporter)

Comment 1

6 years ago
Created attachment 554822 [details]
Chrome search query in wireshark

Comment 2

6 years ago
Firefox doesn't directly query Netbios, that is done by the TCP/IP stack. If a hostname does not contain a dot, by default a Netbios query will be done first. It's slow in your case, because you probably doesn't have a Windows Domain Controller (your home network ?). To disable Netbios lookups : see <http://www.trixya.net/index.php/windows/how-to-disable-netbios-over-tcpip-in-windows>

I'm not sure how Chrome avoids the lookup. Maybe they're always using the full hostname (with domain added) ?
(Reporter)

Comment 3

6 years ago
The main problem is. Chrome does it right, Opera does it right, Firefox doesn't do it right. I've included the opera wireshark output. It queries the DNS, but immediately after that makes the GET query, and at the very end, the sluggish NBNS queries get executed/returned. So this looks like a deeper problem, than what you delineated. Chrome and Opera do the queries in parallel, while Firefox waits for the NBNS answer (at least it looks like it is waiting for it). So make it smarter, because at this very moment, Firefox does not have the competitive edge it used to have and the only thing keeps me from dumping Firefox is Firebug.
(Reporter)

Comment 4

6 years ago
Created attachment 554855 [details]
Opera wireshark output
Dupe of Bug 402411 (maybe others)?
Whiteboard: dupeme
(Reporter)

Comment 6

6 years ago
I'm a programmer myself, so if you tell me what to do, I can do debug, whatever.

Comment 7

5 years ago
I've just tried (new installation, clean profile) a search using the URL bar and it is very slow.

Is the status of this bug still Unconfirmed?

Comment 8

5 years ago
Hi, is this still being looked into?

Comment 9

4 years ago
Using https://addons.mozilla.org/en-us/firefox/addon/httpfox/ I can see that if you search for a single word e.g. "test" then FX tries to visit http://test/ which takes 4.5sec and returns with error message NS_ERROR_UNKNOWN_HOST.

It is only then that it goes on to the normal search but by then you've lost 4.5 seconds.

Note that this does not happen if you search for two words e.g. "test test".

Can someone please confirm?

Comment 10

4 years ago
Could this be linked to the network.dns.ignoreHostonly pref?

Also, is this a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=973383

Comment 11

4 years ago
I'm using 30.0 and this bug is still present. Any one-word search term takes around 3-5 seconds longer than either using two or more words OR searching any amount of words using the dedicated Search UI component.
Component: General → Networking
Product: Firefox → Core
Version: 6 Branch → unspecified

Comment 12

4 years ago
I see this bug has been marked as Resolved:
https://bugzilla.mozilla.org/show_bug.cgi?id=973383

but I can confirm that on Windows and ver 33 this is still an issue as described here:
https://bugzilla.mozilla.org/show_bug.cgi?id=680869#c9

Comment 13

3 years ago
This is fixed for me in Aurora.

https://bugzilla.mozilla.org/show_bug.cgi?id=693808
https://bugzilla.mozilla.org/show_bug.cgi?id=972452

Comment 14

3 years ago
Also works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.