Firefox Report @ nsWebSocketEstablishedConnection::Close() (High Correlation to Yandex Bar)

RESOLVED DUPLICATE of bug 662554

Status

()

Core
Networking: WebSockets
--
critical
RESOLVED DUPLICATE of bug 662554
7 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

6 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Seen while looking at crash stats. https://crash-stats.mozilla.com/report/list?signature=nsWebSocketEstablishedConnection::Close%28%29 to the reports which are Windows.

High correlation to Yandex Bar - 66% (114/174) vs.   4% (3804/97596) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495) and all comments are in Russian.

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsWebSocketEstablishedConnection::Close 	content/base/src/nsWebSocket.cpp:372
1 	xul.dll 	nsWebSocketEstablishedConnection::OnServerClose 	content/base/src/nsWebSocket.cpp:560
2 	xul.dll 	mozilla::net::CallOnServerClose::Run 	netwerk/protocol/websocket/nsWebSocketHandler.cpp:192
3 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
4 	nspr4.dll 	_MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
5 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
6 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
7 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
8 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
9 	xul.dll 	xul.dll@0xb71547 	
10 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:222
11 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3686
12 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:106
13 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
14 	kernel32.dll 	BaseProcessStart
(Reporter)

Comment 1

7 years ago
Adding Kev in case we have a contact at Yandex. 1,100 Crash Reports across all versions in one week.
Danil, thanks. This is indeed a dup of 662554 which is fixed on >= 7.

Doubtful it is yandex related, but there is no STR for it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662554
You need to log in before you can comment on or make changes to this bug.