mimetype entry disappears after editing Handled By

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: db, Assigned: paulkchen)

Tracking

({regression})

Trunk
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: would like for mozilla 0.8)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Start with new empty profile. In the preferences->helperapplications there is
only one entry for text/html. Add a new type and enter the values

Postscript
ps
application/postscript
/usr/X11R6/bin/ghostview

then press OK and you can se the new entry next to text/html. Now edit the new
entry and change the path to something else. Press OK. And now the entry has
disappeared.

Even if I don't change the entry so that it doesn't disappear, when I add
entries for both postscript and PDF I can not get it to work.

It's simply very broken.

This is on build 2001020712, on a Linux Redhat 6.2 system.

Comment 1

18 years ago
I saw the same with 2001-02-07-06/SuSE-x86-Linux-7.1b6.
This is prefs front end (and probably a duplicate)
Assignee: dveditz → matt
Component: Preferences: Backend → Preferences
shrir, you see this? if so, should mscott or bill get it?
QA Contact: sairuh → shrir
confirming. and i see this on winNT and Mac -> all.

not sure if this is the result of an existing bug [shrir?]... also, i noticed
that i cannot edit the Application field of an existing helper app [same as this
bug? another one?] --clicking OK in the edit dialog doesn't dismiss it
[reminiscent of an older bug], but after hitting cancel to dismiss the edit
dialog, then bringing it up again reveals that the Application field is suddenly
empty. hrm.

tentatively handing to mscott --punt as needed. :)
Assignee: matt → mscott
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
OS: Linux → All
Hardware: PC → All

Comment 5

18 years ago
probably related to the changed paul checked in tuesday night.

re-assigning.
Assignee: mscott → pchen
noticed that this also occurs when changing the Handled By radiobutton choice.
resummarizing.

another thing i noticed --pls lemme know if this is the same bug: i create a new
helper app entry *without* specifying a MIME Type, it'll appear as a blank
listing. then i edit it, and give it a MIME Type --after i click OK in the edit
dialog, *another* entry is added to the list, along with the blank one. [this
might be an existing bug, but i cannot recall its number offhand... lemme know
if i should file this. thx!]
Keywords: regression
Summary: edit mime types totaly broken. Entry disappears → mimetype entry disappears after editing Handled By

Comment 7

18 years ago
If I edit a helper app entry and hit enter, even if I don't make any changes,
the entry dissappears (2001020909/Linux).
*** Bug 68362 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 54059

Updated

18 years ago
Depends on: 58811
(Assignee)

Comment 9

18 years ago
Created attachment 25070 [details] [diff] [review]
move deletion of old mapping, also delete mapping we're going to override
(Assignee)

Comment 10

18 years ago
Just attached proposed fix. For some reason, the prefs code is adding a helper 
app mapping with a null mime type. That's why the mapping disappears, we delete 
the old version, then the new version is added, which is bogus. Sigh.

Moving the deletion higher up in the code seems to help, but I'm kinda weary of 
this solution. Would like more testing. While I'm here, also fix case where you 
change the mimetype to override another mapping, need to delete the one you're 
about to override before you save the new one.

In other words, you have a pref for "application/ps" and "application/pdf". You 
edit the mimetype of application/ps to application/pdf. After putting up the 
warning dialog, we wouldn't delete the current application/pdf pref before saving 
the pref you're editing.

Comment 11

18 years ago
sr=mscott 

Comment 12

18 years ago
can we get this checked into the branch as well. a=asa
Whiteboard: would like for mozilla 0.8
How about an r= first?

/be

Comment 14

18 years ago
r=alecf
this was on the xpapp's group's "top 10 annoying features" so adding the
"dogfood" keyword
Keywords: dogfood

Comment 15

18 years ago
*** Bug 68124 has been marked as a duplicate of this bug. ***
*** Bug 68708 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

18 years ago
Checked into trunk and mozilla0.8 branch. I wouldn't be the least bit surprised 
if there were still issues with editing.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
Thisi is working fine on the trunk 0219 (win,mac, linux). Also verified on the 
0215 moz 0.8 builds on win/mac/linux. Sairuh, I see the issue that you mentioned 
in 'Comments From sairuh (se) 2001-02-08 13:33 '. Pls file a bug for 
that.Thanks! Marknig this bug verified.
Status: RESOLVED → VERIFIED
okay, shrir, i filed bug 69708 for the blank entry issue.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.