percentage max-width inside auto layout tables doesn't work

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Sampo Syreeni, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Future
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.7) Gecko/20010114
BuildID:    2001011423

An image with explicitly specified width and height and max-width:100% inside a
table cell (the table uses auto layout) gets squeezed when the screen is narrow.
It seems either the computed value of max-width is derived too soon (before the
column widths have been set) or there is something hazy going on with the
minimum column width calculation routine when only images are present in a
column or when the width is specified via the inline style attribute.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL
2. Resize the browser window so that it's relatively narrow
3. Look at the wider of the two campaign logos

Actual Results:  The logo is squeezed sideways from its specified width

Expected Results:  Same as without max-width specified: the width of the image
should equal the specified width

Comment 1

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001020904

Marking NEW. This should be in layout. Moving it there.
Status: UNCONFIRMED → NEW
Component: Style System → Layout
Ever confirmed: true
QA Contact: ian → amar

Comment 2

17 years ago
URL does not have any percent-width images anymore, so removing it.
I will make a testcase that show the bug instead.
Assignee: pierre → karnaze
QA Contact: amar → petersen

Comment 3

17 years ago
Created attachment 45389 [details]
Testcase

Comment 4

17 years ago
Occasionally the testcase works fine, if so - try RELOAD a few times to see 
the bug.
Keywords: testcase

Comment 5

16 years ago
[Using the testcse with only the first table] (1) when the image is not in the
cache, the image shows up only a few pixels wide because

    Cell 02389808 r=0 a=UC,UC c=UC,UC cnt=4
     Block 02389864 r=0 a=UC,UC c=UC,UC cnt=5
     Block 02389864 d=30,900 me=0
    Cell 02389808 d=60,930 me=30

This occurs even if the nowrap is removed. There is no incremental reflow after
that. 

(2) When the image is in the cache and the viewport is narrower than the natural
width of the image, the image is not displayed correctly, because the max
element size is too narrow. 

    Cell 0118F5B8 r=0 a=UC,UC c=UC,UC cnt=1218
     Block 0118F614 r=0 a=UC,UC c=UC,UC cnt=1219
     Block 0118F614 d=9030,900 me=0
    Cell 0118F5B8 d=9060,930 me=30

Later when the table gives the block an avail width less than 9030, the block
wants a larger desired width, but it is too late.

    Cell 0118F5B8 r=2 a=5310,UC c=5280,UC cnt=1222
     Block 0118F614 r=2 a=5280,UC c=5280,UC cnt=1223
     Block 0118F614 d=9030,900
    Cell 0118F5B8 d=9060,930

-->attinasi. alexsavulov may have insight with problem (2), since it involves
nowrap.
Assignee: karnaze → attinasi
(Assignee)

Comment 6

16 years ago
Looks like more image incremental reflow problems. Accepting to investigate.
Status: NEW → ASSIGNED
Works for me with current trunk build.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Future

Comment 8

16 years ago
REOPEN, trunk build 2001-11-10-08 on Windows 98 SE.
Open the testcase and do a RELOAD to see the bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030221
This problem still exists.  To see it:
Load the testcase - Initial display looks ok.
<shift Reload>
The images are are severely horizontally squished.
bernd, can you figure out what's going on here?  :(

Comment 11

11 years ago
Testcase fails with FF 2.0.0.1

WFM with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061231 Minefield/3.0a2pre

(Resize window smaller, shift-reload) 
Worskforme as well (even without a reflow branch build).  Mats, do you still see this?

Comment 13

9 years ago
-> WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081011 Minefield/3.1b2pre
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.