Feature request for a Hidden pref (or public pref at menu) to activate shrinkable tabs on firefox

RESOLVED DUPLICATE of bug 1404465

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1404465
6 years ago
2 months ago

People

(Reporter: Luciano A. Ferrer, Unassigned)

Tracking

6 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110814102054

Steps to reproduce:

I (as many others*) wanted shrinkable tabs, instead lots of scrollable tabs

* I saw commentes that is dumb UI to have tabs of 16px, but some people find it really helpful. Most sites uses favicons, so you can recognize them, and other peoples rearange the order of tabs so they know where are placed, they may use shortcuts to go to them too, etc... some people have sections about things to do, things to read, things to buy, etc... If you you have more than 20-30 tabs, it works great and you dont waste time moving over a scroll searching and reading tabs


Actual results:

Dao removed it :)


Expected results:

This is a feature request to add a new hidden pref (or a public pref at menu if you find it to be better) to activate shrinkable tabs.

As you may already know we used to do this using about:config and min/max width prefs.
After DAO "fixed" this feature on firefox 4 https://bugzilla.mozilla.org/show_bug.cgi?id=574654
the only way to achieve this is editing the userchrome file:
https://bugzilla.mozilla.org/show_bug.cgi?id=574654#c110 (using a minimum of 16px for example)
or using third party addons, that my not be updated or work as intended.

I think that an option to achieve this behavior, without editing files or using external addons, will do life happier of many people.

Best regards.
(Reporter)

Updated

6 years ago
OS: Linux → All
Hardware: x86 → All

Comment 1

6 years ago
It's was previous wontfix'ed in bug 648218.
(Reporter)

Comment 2

6 years ago
I like Leyra comments there: https://bugzilla.mozilla.org/show_bug.cgi?id=648218#c3
Not asking to return options, but adding a new/better one for all the people... (as we do not ask for a fixed width tab)

btw, if this is implemented somewhere, It would be whise to set browser.tabs.closeButtons to 3, so to have just 1 close button at right
(there is no place for it in a max 30px tab)

Updated

6 years ago
Depends on: 677302

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
A few related bugs/changes:
Bug 597564 - Default minimum tab width should be smaller to prevent tab scroll
Bug 685059 - Remove empty placeholder icon when a page has no favicon
Showing close button even for lower tab widths (by reducing browser.tabs.tabClipWidth)

Comment 4

6 years ago
If it ain't broke, don't fix it.

Why were shrinking tabs replaced with the "comedy carousel" in the first place?

Comment 5

6 months ago
What needs to be done for this to happen?
I suspect it's not an implementation effort issue - however if it is: would a patch for this get reviewed/accepted? 

I suspect it might be easier to first have the hidden pref and introduce an UI for it in a different bug.
Flags: needinfo?(dao+bmo)
See Also: → bug 1404465

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
No longer depends on: 677302
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
See Also: bug 1404465
Duplicate of bug: 1404465
You need to log in before you can comment on or make changes to this bug.