Last Comment Bug 681360 - Async initialization for Orion TextView
: Async initialization for Orion TextView
Status: RESOLVED FIXED
[orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 702331
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 09:15 PDT by Mihai Sucan [:msucan]
Modified: 2011-12-15 04:37 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mihai Sucan [:msucan] 2011-08-23 09:15:09 PDT
The current Orion TextView initialization is synchronous with some code that would need to become async. The current approach seems to cause random failures for us. See orion.textview.TextView._init().

We need to fix this problem upstream:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=349627
Comment 1 Mihai Sucan [:msucan] 2011-10-10 13:01:07 PDT
Async initialization has been added upstream but no "load" event. Also, there's no a DOMAttrModified event handler which slows down the parent document DOM operations. "Luckily" we are not affected because the SourceEditor re-wraps Orion into an iframe, so only that one is affected.
Comment 2 Mihai Sucan [:msucan] 2011-12-15 04:37:49 PST
This is now entirely fixed upstream and the code has been integrated into our codebase, see bug 702331.

Note You need to log in before you can comment on or make changes to this bug.