Last Comment Bug 681425 - Tabs in Firefox (Preferences) should look and feel like native OS X tabs
: Tabs in Firefox (Preferences) should look and feel like native OS X tabs
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Mac OS X
: -- enhancement (vote)
: Firefox 11
Assigned To: Markus Stange [:mstange]
:
Mentors:
: 699601 (view as bug list)
Depends on: 713446
Blocks: 667456 712083
  Show dependency treegraph
 
Reported: 2011-08-23 12:21 PDT by Dominic Spitaler
Modified: 2011-12-25 08:15 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Comparison between the tabs in Firefox Preferences and native OS X Lion tabs (122.58 KB, image/png)
2011-08-23 12:21 PDT, Dominic Spitaler
no flags Details
v1 (1.25 KB, patch)
2011-11-12 10:24 PST, Markus Stange [:mstange]
dao+bmo: review+
Details | Diff | Splinter Review

Description Dominic Spitaler 2011-08-23 12:21:04 PDT
Created attachment 555158 [details]
Comparison between the tabs in Firefox Preferences and native OS X Lion tabs

The tabs under Preferences->Advanced (and maybe elsewhere?) don’t look and feel exactly like native OS X tabs.

- They shouldn’t have a blue highlight/glow around them
- Text in the selected tab should be white (in Lion)
- Tab switching should occur on a mouse-release event and not on mouse-down
- Pressed state (for selected and unselected tabs) is therefore missing too

This is of course not very severe, or even important, but let’s track it anyway. Maybe it’s an easy fix.
Comment 1 Stephen Horlander [:shorlander] 2011-08-23 12:34:33 PDT
(In reply to Dominic Spitaler from comment #0)
> - They shouldn’t have a blue highlight/glow around them

That is the focus ring, which is intended. It should only appear if you tab to the control though.
Comment 2 Dominic Spitaler 2011-08-23 13:40:28 PDT
I thought it was intended, I just wanted to point out that it’s unusual for OS X.
Comment 3 Dominic Spitaler 2011-08-23 13:41:28 PDT
(In reply to Dominic Spitaler from comment #2)
> I thought it was intended, I just wanted to point out that it’s unusual for
> OS X.

Wops, sorry now I get it. it’s meant for keybord-access, sorry.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-11-03 19:23:27 PDT
*** Bug 699601 has been marked as a duplicate of this bug. ***
Comment 5 Markus Stange [:mstange] 2011-11-12 10:24:53 PST
Created attachment 574070 [details] [diff] [review]
v1
Comment 6 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-28 13:16:50 PST
Markus, can this be landed now or are you waiting to land it with something else?
Comment 7 Markus Stange [:mstange] 2011-11-28 13:26:25 PST
Oops, no, this can land.
Comment 8 Dão Gottwald [:dao] 2011-11-29 07:05:00 PST
https://hg.mozilla.org/mozilla-central/rev/9ecb0201e044
Comment 9 Dominic Spitaler 2011-12-04 13:30:03 PST
While looking like native OS X tabs, they do not behave exactly like them. A tab should be activated on release not on press. I also still get the blue focus ring when switching between tabs with the mouse.
Comment 10 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-12-05 11:22:05 PST
(In reply to Dominic Spitaler from comment #9)
> While looking like native OS X tabs, they do not behave exactly like them. A
> tab should be activated on release not on press. I also still get the blue
> focus ring when switching between tabs with the mouse.

Thanks for following up on that, but can you file a new bug for the clicked state / behavior part of it? This bug got morphed into just handling the color of the tabs.
Comment 11 Dominic Spitaler 2011-12-19 12:42:09 PST
done that: https://bugzilla.mozilla.org/show_bug.cgi?id=712083

Note You need to log in before you can comment on or make changes to this bug.