Last Comment Bug 681480 - Conditional forward button on gnomestripe performs animation when switching tabs
: Conditional forward button on gnomestripe performs animation when switching tabs
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: Firefox 10
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on: 682534
Blocks: 677027
  Show dependency treegraph
 
Reported: 2011-08-23 14:40 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2011-10-16 10:36 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Animation of forward button (628.67 KB, video/mp4)
2011-08-23 14:40 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details
patch (5.62 KB, patch)
2011-10-11 08:48 PDT, Dão Gottwald [:dao]
shorlander: review+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2011-08-23 14:40:42 PDT
Created attachment 555208 [details]
Animation of forward button

Steps to reproduce:
Open two tabs (A,B)
In tab A, navigate to a page and click the back button (thus showing the forward button).
In tab B, make sure that the forward button is not showing.
Give focus to tab A.
Now give focus to tab B.

Expected results:
No animation of the forward button appearing, since the user is not navigating forward/backward.

Actual results:
The forward button appears/disappears with animation. See attached video.
Comment 1 Kemcy BEST 2011-08-24 05:47:33 PDT
I can confirm it on
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110824 Firefox/9.0a1

This behavior unnecessarily steals user's attention. Is there a way to disable this animation (either for the same tab or tab-switching)? Is there a way to disable conditional forward button and make it always there?
Comment 2 Dão Gottwald [:dao] 2011-10-11 08:48:22 PDT
Created attachment 566238 [details] [diff] [review]
patch

This mostly copies some infrastructure from the winstripe patch. There's more to come in bug 682536.

I also shortened the transition length.
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-16 10:36:17 PDT
https://hg.mozilla.org/mozilla-central/rev/f861fcef59da

Note You need to log in before you can comment on or make changes to this bug.