www.businessmobile.fr - A button in a fieldset incorrectly placed after an input element

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: jaclemire, Unassigned)

Tracking

Details

(Whiteboard: [hardcoded px width])

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
Created attachment 555381 [details]
nightly_bmfr1.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110824 Firefox/9.0a1
Build ID: 20110824030813

Steps to reproduce:

Browse this page http://www.businessmobile.fr/
the black GO button is 'under' newsletters.
see attachment


Actual results:

Can't find the GO button -- barely visible
The GO button is perfectly visible with Chrome and Opera


Expected results:

Show GO button to the right -- see attachments
(Reporter)

Comment 1

7 years ago
Created attachment 555382 [details]
The same area but displayed with Chrome
(Reporter)

Updated

7 years ago
Summary: A button in a fieldset incorrectly place → A button in a fieldset incorrectly placed after an input element
(Reporter)

Comment 2

7 years ago
Remark:  this is a bad title. I did my best to find out where were the elements in the actual HTML. I may be wrong with fieldset.
(Reporter)

Comment 3

7 years ago
Created attachment 555389 [details]
From an example w3c schools, the fieldset element -- chrome version

I have removed the br on Email line. And the next element is placeed to the right.
(Reporter)

Comment 4

7 years ago
Created attachment 555391 [details]
From an example w3c schools, the fieldset element -- nightly version

Firefox does not 'remove' the break -- it is as if the break is always there.

Comment 5

7 years ago
It works if disabled HWA.
OR
It works if Text size zoom out.

Duplicate of Bug 593802 ?
The page looks fine to me in a current Nightly on Linux using a fresh profile.
If I set (in Preferences) "Minimum font size" to 13, then I get the broken layout.

http://www.businessmobile.fr/2010/css/businessmobile.htm?v=20100319001
.searchBar {
    width: 394px;
}

when I remove that explicit width, the page looks fine also with the
minimum font size set.

-> TE
Assignee: nobody → french
Component: General → French
OS: Linux → All
Product: Firefox → Tech Evangelism
QA Contact: general → french
Hardware: x86 → All
Summary: A button in a fieldset incorrectly placed after an input element → www.businessmobile.fr - A button in a fieldset incorrectly placed after an input element
Whiteboard: [hardcoded px width]
Version: 9 Branch → unspecified

Comment 7

5 years ago
URL forwards to another page with a new design.
[closeme]

Comment 8

5 years ago
Tested and redirection to a new domain.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.