Selecting File|Open File Location with a frameset allows page in editor

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
P2
normal
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: tapio.markula, Unassigned)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
using framesets might lead to un-framed page, where can't go back to the frameset
http://www.nic.fi/~tapio1/Yleiset - I got them work also in Mozilla 0.7!

Comment 1

17 years ago
please provide more detailed steps how to reproduce the problem...
Is this supposed to be an editor bug? if so, is the problem that if you load a
frameset document in editor the editor will convert it to a regular document and
throw away the <frameset> and <frame> tags?
One more question.  What DTD are you using for your frameset?

Comment 4

17 years ago
That link uses: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Frameset//EN">

Comment 5

17 years ago
If you use a link on that page, his menu is gone. That should be the problem i
guess.

Comment 6

17 years ago
If you display the pages in the current build (2/9/01) it renders fine in the 
browser, if you select to edit the page from File|Edit Page, a warning dialog is 
displayed telling the user that editing framesets is not supported and closes 
the edit session. If you open Composer and select File|Open File Location, it 
opens the file in the Composer window in a browse mode and not in an edit mode.

changing summary to what I think the problem is meant to be

assigning to sfraser -- Simon, shouldn't the File|Open File Location also catch 
that this is a frameset?
Assignee: beppe → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: a frameset problem → Selecting File|Open File Location with a frameset allows page in editor

Comment 7

17 years ago
It should detect the frameset in that second case too. I've no idea why it would 
not.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
Priority: -- → P2

Comment 8

17 years ago
moving to 1.0
Target Milestone: mozilla0.9.1 → mozilla1.0

Comment 9

16 years ago
-> editor owners
Assignee: sfraser → kin
Status: ASSIGNED → NEW

Comment 10

16 years ago
-->composer
Assignee: kin → syd
Component: Editor: Core → Editor: Composer
OS: other → All
Hardware: Other → All

Comment 11

16 years ago
I got the dialog saying you can't edit this when I tried opening from composer,
which contradicts beppe's report and suggests this bug is fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Works For Me as well - marking Verified
Status: RESOLVED → VERIFIED

Comment 13

15 years ago
reassign bugs in case they are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.