Closed Bug 681821 Opened 9 years ago Closed 8 years ago

Nightly Tester Tools 3.1.5.1 version back-numbered, confusing AOM

Categories

(Other Applications Graveyard :: Nightly Tester Tools, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dave, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

The latest Nightly Tester Tools uploaded to Add-Ons (https://addons.mozilla.org/en-US/firefox/addon/nightly-tester-tools/) is 3.1.5.1, but the previous version is 3.1.7 so AMO is not auto-upgrading to the newer version.

It's also confusing at a human level. Should users be switching back to the future to 3.1.5.1? Since 3.1.7 isn't FF6 compatible I would assume yes, but I would much rather have someone confirm that.

The last few reviews have commented on this also.
See bug 663272 comment #12. The NTT version upgrade was erroneously numbered 3.1.5.1 where it should have been 3.1.7.1. The next time NTT is updated at BMO (but when will that be?) it should have the correct versions (both NTT and Firefox).
Blocks: 663272
Status: UNCONFIRMED → NEW
Ever confirmed: true
Problem has been fixed (but I don't know exactly where so this is WFM not FIXED) by uploading a version 3.2 at AMO.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.