Last Comment Bug 681895 - Tag <pre> is ignored on Firefox under Mac OS 10.6/10.7 (Cyrillic script)
: Tag <pre> is ignored on Firefox under Mac OS 10.6/10.7 (Cyrillic script)
Status: VERIFIED FIXED
[qa!]
: verified-aurora, verified-beta
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Jonathan Kew (:jfkthame)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 02:03 PDT by Valentine Silvansky
Modified: 2011-11-22 06:54 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected
affected
fixed


Attachments
patch, v1 - update Cyrillic font prefs for OS X (1.95 KB, patch)
2011-08-25 04:24 PDT, Jonathan Kew (:jfkthame)
smontagu: review+
Details | Diff | Splinter Review

Description Valentine Silvansky 2011-08-25 02:03:47 PDT
User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Open any page with <pre> tags (for example, http://www.amystrange.org/UNX-calendar.html or http://chords.auctyon.ru/songs/?song=letileytenant ) 


Actual results:

Any text in <pre> tag is displayed w/o monospacing font. For example, guitar tabs are really ugly.


Expected results:

Text should have been rendered with monospace font.
Comment 1 j.j. 2011-08-25 02:25:17 PDT
Please try basic trouble shooting.
http://support.mozilla.com/kb/Basic%20Troubleshooting
Comment 2 Valentine Silvansky 2011-08-25 02:38:10 PDT
Nothing helped.
Comment 3 Jonathan Kew (:jfkthame) 2011-08-25 04:01:37 PDT
This is specific to Cyrillic-script pages/locales, and occurs because the default font names specified in Firefox preferences are the old "CY" variants of Times/Helvetica/Monaco, but these are no longer shipped with current versions of OS X.

See http://mxr.mozilla.org/mozilla-central/source/modules/libpref/src/init/all.js#2110 and following.

You can fix the problem locally by selecting appropriate fonts in the Preferences dialog, but obviously we should update the initial defaults. With standard Unicode-based fonts now available on the platform, the script-specific "CY" fonts from classic Mac OS are obsolete.
Comment 4 Jonathan Kew (:jfkthame) 2011-08-25 04:24:06 PDT
Created attachment 555697 [details] [diff] [review]
patch, v1 - update Cyrillic font prefs for OS X

I don't have a 10.7 system to test this on, but it resolves the problem for me on 10.6 at least.

Interestingly, the "Charcoal CY" font is still present on 10.6. Can someone confirm whether it is also shipped on 10.7?
Comment 5 Jonathan Kew (:jfkthame) 2011-08-25 08:18:24 PDT
Pushed to mozilla-inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c93150bf4479
Comment 6 Mats Palmgren (:mats) 2011-08-25 10:26:55 PDT
(In reply to Jonathan Kew from comment #4)
> Interestingly, the "Charcoal CY" font is still present on 10.6. Can someone
> confirm whether it is also shipped on 10.7?

Yes, I see Charcoal CY, Geneva CY and Helvetica CY in the Font book,
but no other CY.
Comment 7 Ed Morley [:emorley] 2011-08-25 18:41:53 PDT
http://hg.mozilla.org/mozilla-central/rev/c93150bf4479
Comment 8 j.j. 2011-08-25 18:54:08 PDT
This seems a serious bug for the affected locales with a trivial fix.
Should it land on Aurora and Beta?
Comment 9 Vlad [QA] 2011-11-22 06:54:33 PST
Setting resolution to Verified Fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0 beta 2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111121 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111121 Firefox/11.0a1

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111121 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111121 Firefox/11.0a1

I have used the steps from the description in order to verify this and the text is rendered as expected.

Note You need to log in before you can comment on or make changes to this bug.