misleading 404 error message when loading a too old crash report

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: uG-OCeAN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Tried to view a submitted crash report from "about:crashes"
https://crash-stats.mozilla.com/report/index/bp-f1e461eb-5a25-4179-9b3d-ba35c2100610


Actual results:

Took me to a "Page not Found" saying:
"The requested page could not be found.

If you followed a dead link on the website, please submit a Bugzilla ticket describing what happened, and please include the URL for this page."


Expected results:

Should have displayed a crash report
(Reporter)

Updated

7 years ago
Moving to Socorro component.
Assignee: robert → nobody
Component: Reporter → Socorro
QA Contact: reporter → socorro
the last six digits of the ooid indicate that the crash was submitted on June 10, 2010. Due to storage constraints, we do not keep crashes that old.

We ought to have a better error message than simply "page not found".

Comment 3

7 years ago
Correcting the summary to tell what the actual error is. I feel like we already have some report for this somewhere, but I'm not completely sure.
Summary: crash [@ bp-f1e461eb-5a25-4179-9b3d-ba35c2100610] → misleading 404 error message when loading a too old crash report
There is a bug someplace covering improving the error messaging, I will find it and dupe this bug.
Bug 680013 covered the use case of recently submitted crashes giving a 404, but I don't see a comment specific to the messaging related to older crashes.
If a crash is not found I now get:

Crash Not Found

We couldn't find the OOID you're after. If you recently submitted this crash, it may still be in the queue.

If you belive this message is an error, please submit a Bugzilla ticket describing what happened, and please include the URL for this page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.