JIT compiler causes non-updating caret

RESOLVED INVALID

Status

()

Core
JavaScript Engine
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Pontus, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Bug appears basically in any textbox, such as Facebook type message, messages in forums, etc, that are just non-formatted textboxes. It happens if you navigate caret (cursor) using the keyboard instead of clicking with mouse.


Actual results:

Caret is not updated. Remains at old position whereas the new position gets a new caret. Therefore the text gets garbled and it's hard to see where you are typing.

Bug appears also with all extensions disabled, but not in safe mode. It also appears with hardware acceleration disabled, but disappeared when disabling the JIT compiler. 


Expected results:

I expected normal text input with only one caret. I recommend that users disable JIT compiler until the bug is resolved.
Assignee: nobody → general
Component: Keyboard Navigation → JavaScript Engine
Product: Firefox → Core
QA Contact: keyboard.navigation → general
Whiteboard: js-triage-needed
(In reply to Pontus from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101
> Firefox/6.0
> Build ID: 20110811165603
> 
> Steps to reproduce:
> 
> Bug appears basically in any textbox, such as Facebook type message,
> messages in forums, etc, that are just non-formatted textboxes. It happens
> if you navigate caret (cursor) using the keyboard instead of clicking with
> mouse.

You mean a Facebook comment box, and left and right arrows? I tried that but could not reproduce.
We can't reproduce and these JITs are gone. Please file a new bug if you're still seeing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.