Closed Bug 682028 Opened 8 years ago Closed 8 years ago

Rename the Mochitest 'loops' feature to be 'repeat'

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla9

People

(Reporter: mdas, Assigned: mdas)

Details

Attachments

(1 file, 1 obsolete file)

'loops' has shown to be a confusing name for the feature. We will be moving to rename it to 'repeat' to avoid this confusion.

Usage examples:

python runtests.py --test-path=Harness_sanity/test_sanity.html --repeat=1

or

TEST_PATH=Harness_sanity/test_sanity.html EXTRA_TEST_ARGS='--repeat=1' make -C $(objdir) mochitest-plain

will repeat the test once for a total of 2 test runs.
Comment on attachment 556590 [details] [diff] [review]
replace loops with repeat and give a more useful help message

Review of attachment 556590 [details] [diff] [review]:
-----------------------------------------------------------------

just a simple comment cleanup.

::: testing/mochitest/runtests.py
@@ +547,5 @@
>          logFile -- logs test run to an absolute path
>          totalChunks -- how many chunks to split tests into
>          thisChunk -- which chunk to run
>          timeout -- per-test timeout in seconds
> +        repeat -- How many times to run the test

this is sort of misleading.  This should be how many times to repeat the test, repeat=1 -> test runs twice.

Maybe this should be in the help also.
Attachment #556590 - Flags: review?(jmaher) → review+
http://hg.mozilla.org/mozilla-central/rev/98d6d376f140
Status: NEW → RESOLVED
Closed: 8 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla9
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.