cannot drag the window with the toolbar when a sheet is open

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: passfree, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.861.0 Safari/535.2

Steps to reproduce:

This bug was found in the preferences window but I believe it applies generally to all windows.

In MacOS we can drag the window with the toolbar if it has the unified style applied on it. You can easily test this by opening the preferences windows and drag it by clicking anywhere on the toolbar but not the buttons. If you now go to Advanced, Network, Settings the Proxy configuration window will open as a child of the preferences window. Now if we try to drag the parent window (Preferences Window) by the toolbar you will see that this is not possible. We can still drag it by the titlebar.
Status: UNCONFIRMED → NEW
Component: Preferences → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
QA Contact: preferences → cocoa
Hardware: x86 → All
Summary: cannot drag the window with the toolbar when another model window is opened → cannot drag the window with the toolbar when a sheet is open
No longer an issue in the current Nightly (25). Marking as WORKSFORME. (This is 10.8, but since the bug says this happens on all versions of OS X, I'll assume 10.8 implies the rest, feel free to reopen if this is an issue on other platforms)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.