Bring back the stats CSV format

RESOLVED FIXED in 6.2.9

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: jbalogh, Assigned: jbalogh)

Tracking

6.2.9
x86
Mac OS X

Details

(Assignee)

Description

7 years ago
Right now it's broken because that code looks weird.
Target Milestone: 6.2.3 → Q3 2011
(Assignee)

Updated

7 years ago
Duplicate of this bug: 686640

Comment 2

7 years ago
Steps:
======
1. Load https://addons-dev.allizom.org/en-US/firefox/addon/adblock-plus/statistics/downloads/?last=90
2. Click on the link "Export as CSV"

Downloads by Date<a id="export_data" href="">Export as CSV</a>

Result: same page loads: https://addons-dev.allizom.org/en-US/firefox/addon/adblock-plus/statistics/downloads/?last=90
(Assignee)

Updated

7 years ago
Target Milestone: Q3 2011 → 6.2.9

Updated

7 years ago
Blocks: 611705
The stats load data off of .json URLs.  The idea here was to be able to just s/.json$/.csv/ and have the same data.  Looks like that code tracebacks right now though.

If we can't fix those tracebacks, can we still point to the remora csvs?  Do they line up 1:1 with what we're showing in the new stats pages?
(Assignee)

Comment 4

7 years ago
B A M. https://github.com/mozilla/zamboni/commit/d3707b5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

7 years ago
Fixed the links in the pages.

https://github.com/mozilla/zamboni/commit/1363bde
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.