If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[ASO] improve the Firefox product name for Google Play

RESOLVED FIXED

Status

Websites
Other
--
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: kohei, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
http://www.google.com/search?hl=en&q=browser+android

> Firefox - Android Market
> https://market.android.com/details?id=org.mozilla.firefox

I'd like to propose to add "web browser" words to the product name for Android Market, like Dolphin, Opera, Skyfire, etc.

> Firefox Web Browser - Android Market

would be better from the view point of SEO.
(Reporter)

Updated

5 years ago
Blocks: 722846
(Reporter)

Updated

5 years ago
Summary: [SEO] improve the Firefox product name for Android Market → [SEO] improve the Firefox product name for Google Play
(Reporter)

Comment 1

5 years ago
Firefox is only browser which doesn't include the word "browser" in the app name :(
https://play.google.com/store/search?q=browser&hl=en

It should be fixed ASAP, without waiting for the Native UI launch.

Comment 2

5 years ago
CCing Jaclyn and Chris. What's the process of getting this reviewed?
(Reporter)

Comment 3

5 years ago
Chrome is simply named Chrome Beta, though, the word "browser" is definitely required in the app name from the perspective of ASO (App Store Optimization).
https://play.google.com/store/apps/details?id=com.android.chrome
Summary: [SEO] improve the Firefox product name for Google Play → [ASO] improve the Firefox product name for Google Play

Comment 4

5 years ago
I think stakeholders who would have a good idea or opinion would be Release Management (how adding this would affect us) and brand management (whether "Firefox Browser" would be in line) cc'ing akeybl and jslater/pete

Comment 5

5 years ago
(In reply to Jaclyn Fu from comment #4)
> I think stakeholders who would have a good idea or opinion would be Release
> Management (how adding this would affect us) and brand management (whether
> "Firefox Browser" would be in line) cc'ing akeybl and jslater/pete

At the very least, the word Browser would not be localized in the title.

As for technical issues, I don't expect there to be any, but CC'ing Aki anyway. Can we change the name of https://play.google.com/store/apps/details?id=org.mozilla.firefox_aki to "test l10n 2" or something similar? I have the earlier version on my phone and can see what happens.

My understanding is that a change to the Google Play product name will not affect the name of the application itself, or the update experience in any way. We'll verify.

Comment 6

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #5)
> Can we change the name of
> https://play.google.com/store/apps/details?id=org.mozilla.firefox_aki to
> "test l10n 2" or something similar? I have the earlier version on my phone
> and can see what happens.

Changed.
I had to change it per locale (fr and zh-TW); this list is separate from the list inside the apk.

Comment 7

5 years ago
Calling it "Firefox web browser" seems like a good option to me...I'd expect something like that would help us move up the page on searches like this one:
https://play.google.com/store/search?q=+browser&c=apps

Pete, any objections or concerns?

Also, I assume we'd change the Beta descriptor to something similar as well?

Comment 8

5 years ago
Changing the name seems like the right path.  Dave Slater agrees.  Question - do we lose any of our history when we change the name?  It would be good to know. 

Many thanks
Pete
(Reporter)

Comment 9

5 years ago
Many browsers actually localize their app name.
English: browser https://play.google.com/store/search?q=+browser&hl=en
Japanese: ブラウザ https://play.google.com/store/search?q=+browser&hl=ja
(Reporter)

Comment 10

5 years ago
Beta: Bug 729601 Comment 19
L10n: Bug 737159 Comment 3

Comment 11

5 years ago
Is it confirmed that no technical issues will occur if we change the title to "Firefox Web Browser"?
I was looking at the Nexus 7 manual posted online and reading a little blurb about Flash support.

http://cl.ly/09330c3H2U3g1x3s1Q1W

From what I gather here, Google is going to at some point publish the Android Browser onto the market (guessing based on the manual here for Nexus 7). Going by what's written it may simply be titled 'Browser'; so this just reinforces some urgency to get Firefox up there in the listings: https://play.google.com/store/search?q=browser&c=apps
(Reporter)

Comment 13

5 years ago
Chrome for Android out of Beta
http://googlechromereleases.blogspot.jp/2012/06/chrome-for-android-out-of-beta.html
(Reporter)

Comment 14

5 years ago
https://wiki.mozilla.org/Firefox/Planning/2012-11-28#Mobile_3
> Firefox has been renamed to Firefox Browser for Android 
> to make Firefox easier to find via search in the Google Play Store. 
> So far we've seen an increase in downloads and are now in the top-5 
> for all browser related searches.

https://play.google.com/store/apps/details?id=org.mozilla.firefox&hl=en
Looks like en-US only. Sigh.

Comment 15

4 years ago
The browser is now called "Firefox Browser for Android"
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Depends on: 905994
You need to log in before you can comment on or make changes to this bug.