Change Password button on Edit Your Profile doesn't save form data

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: ozten, Assigned: tofumatt)

Tracking

({ux-consistency})

Details

(Reporter)

Description

7 years ago
This is a UX bug.

1) Login
2) Click Edit Your Profile
3) Modify your First Name (or other attributes
4) Click the 'Change Password' button

Actual:
Move to /en-US/password_change.
First name is not updated

Expected:
This link shouldn't look like a button. it is a form of navigation.
Otherwise if it is a button, it should submit the form and then eventually redirect to /{locale}/password_change.
(Reporter)

Updated

7 years ago
Keywords: ux-consistency
This should be fixed in 1.0 Triaging as such :)
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → 1.0
(Assignee)

Comment 2

7 years ago
I've closed this up in an upcoming commit; the password link is now styled as a link, not a button. It still doesn't submit form data; I'd be open to a JS alert warning users that they have unsaved data, though the back button on any modern browser should refill their information if I recall correctly.

I'll close the bug when it's up on -dev
(Assignee)

Updated

7 years ago
Assignee: nobody → tofumatt
Status: NEW → ASSIGNED
This password link is styled as a link on staging and dev now. The form is not submitting, but that might be due to bug 688121
(Assignee)

Comment 4

7 years ago
The form should *not* submit when you click the change password link; the link takes you to another page (this is expected behaviour of a link).

Now that there isn't confusion about the password link looking button-y (implying saving entered info) I'd consider this fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified we have a Change Password link, not a button.
Status: RESOLVED → VERIFIED

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: 1.0 → ---
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.