metrics connection to amo database in phx is very slow

RESOLVED INVALID

Status

mozilla.org Graveyard
Server Operations
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: Nelson, Assigned: mpressman)

Tracking

Details

(Reporter)

Description

7 years ago
We're moving our amo-personas synch jobs to write to the new amo db location but the connection is very slow and we'd like some help dealing with that.

The job needs to perform a few hundreds of thousands of updates (one for each persona), and we need some help figuring out where the bottlenecks may be.

Updated

7 years ago
Assignee: server-ops → mpressman
Yeah, this is expected.

I'd say the least time consuming way of solving this is to move all the jobs to phx1. Writing to phx1 from sjc1 will only go so much faster, nothing much can be done to improve that.

I'll let Matt decide. I don't think it's the databases performance that's the issue here, just the internets. Writing from within a datacenter and across datacenters are entirely different beasts.
1 - is this still an issue?

2 - if it is, what is the source and destination addresses for this transaction?

3 - Shyam is right, you are going to be at the mercy of the internet here.  There were a couple of days back around july/aug where the internet as a whole had some major routing issues so this may have been one of those days, hence question #1

Comment 3

6 years ago
I don't think this is relevant anymore...
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.