Thread pane is not updated after the folder charset is changed.

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
P4
normal
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

({intl})

Trunk
Future
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
****observed with 2001-02-08 win32, linux and Mac build****

After changing the folder charset, the thread pane is not updated until you 
reselect that folder.

Steps to reproduce:
1. Select a folder which contains some messages with wrong or no MIME headers.
2. Select Edit | Properties... | Character Coding
3. Select the right charset, apply the checkmark and click on OK
The folder stays selected, but the thread pane is not updated until you reselect
the folder by going to a different folder and then coming back to it.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Priority: -- → P4
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 1

17 years ago
There is an update problem. Workaround is to go to other folder, and then come
back. 

Don't believe this is nsbeta1 material, please correct me, if i am wrong.
Keywords: intl

Comment 2

16 years ago
WORKSFORME on today's build (on linux)
(Assignee)

Comment 3

16 years ago
WFM, used 4/30 commercial branch win32
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
I saw this again with 05/14 1.0.0 branch build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 5

16 years ago
This is working for me using 05/14 1.0.0 branch build on Windows 2000.

I tested a folder which contains message subjects without MIME charset but
actually encoded as ISO-2022-JP. After I set a folder chaset to ISO-2022-JP, the
subjects in thread pane shown correctly. Then I revert the charset to ISO-8859-1
then the subjects in thread pane turn to garbage again.
(Reporter)

Comment 6

16 years ago
I'm also using 05/14 1.0.0 build on a W2K. 
I noticed that with the default mail window size, the thread pane can be updated
after selecting a folder charset, but once I resize the window size, it won't be
updated anymore after I change the folder charset.
(Assignee)

Comment 7

16 years ago
I think the remaining problem can be filed separately.
Mark as WFM.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.