Open Bug 682483 Opened 10 years ago Updated 9 years ago

[OGL] No GL acceleration on T-Mobile MyTouch 4G (Android)

Categories

(Core :: Graphics, defect)

ARM
Android
defect
Not set
normal

Tracking

()

People

(Reporter: goodvin, Unassigned)

References

Details

OpenGL acceleration is disabled on T-Mobile MyTouch 4G (HTC Glacier).

about:support says:
"Adapter Description" - Android HTC Glacier HTC glacier
"WebGL Renderrer" - "Qualcomm -- Adreno 205 -- OpenGL ES 2.0 1403843
"GPU Accelerated Windows" - "0/1. Blocked for your graphics card because of unresolved driver issues."

The phone is running stock (updated by T-Mobile) Gingerbread 2.3.4, Software number 2.19.531.1. It didn't work on Android 2.2.1 before update either.

Setting 
pref("layers.acceleration.disabled", false);
pref("layers.acceleration.force-enabled", true);
and restarting the browser didn't make a difference.

Without GL acceleration, HTML5 YouTube videos play very choppy and slow the whole phone down to almost unusable state.

The issue looks similar to bug 621741 but for a different phone. Bug 607684 should be made dependent on this one.
This indeed sounds similar to bug 621741 -- if OpenGL acceleration is disabled even after being force enabled, the most likely explanation is that the creation of a GL context in nsWindow::GetLayerManager() is failing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Firefox 7 Beta does not have acceleration either.
Version: 6 Branch → 7 Branch
Blocks: 698673
No longer blocks: opengl-mobile
Version: 7 Branch → Trunk
George is going to see if he can reproduce this.
You need to log in before you can comment on or make changes to this bug.