replacing flash plugin file while Firefox is running makes add-on manager confused about the state of the plugin

VERIFIED DUPLICATE of bug 554780

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 554780
6 years ago
6 years ago

People

(Reporter: aceman, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 556277 [details]
screenshot of add-on manager

Steps to reproduce:
1. start Firefox
2. make Flash plugin enabled
3. go to the folder where the plugin file is located
4. replace the plugin file with a new version (by deleting the old one and copying new one)
5. return to Firefox and open add-on manager

Result:
Add-on manager is confused about the plugin:
- title says it is "(disabled)" but the color says otherwise
- there are buttons to Disable and also Enabled
- there is a button for Preferences (for a plugin!)
- going to a page using Flash makes FF hang for a minute when the object is painted, then it runs fine. Flash is enabled and works. Further visits to the page are normal speed.

Expected result:
The plugin should be enabled (as long as that is the default action with new detected plugins) and the state should be correctly depicted

On FF9 the situation is the same.
(Reporter)

Comment 1

6 years ago
The buttons do not work either way. Only the "Remove" button pretends to "work". It removes the plugin from view (as it does for extensions). However, after FF restart the plugin is there and the state is correct (enabled) and plugins work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554780
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.