Crash, null pointer deref [@ GraphWalker<scanVisitor>::DoWalk ]

RESOLVED DUPLICATE of bug 500105

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 500105
8 years ago
8 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

({crash})

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

Is this the right fix? I don't want to hide a bug, if the real bug is that a null pointer was there in the first place.
Attachment #556291 - Flags: review?(jwalden+bmo)
Severity: normal → critical
Keywords: crash
Yeah, this looks like the same thing as bug 500105, which happens on all platforms.  About half of these crashes show up as null dereferences, but I think pi shouldn't be null here.  I'm not sure if there is just sometimes an extra null being stored, so we could skip over it and all would be fine, or of this means we've totally gone off the rails, and null-checking will just make us crash later.
Assignee: general → nobody
Component: JavaScript Engine → XPCOM
QA Contact: general → xpcom
Attachment #556291 - Flags: review?(jwalden+bmo) → review?(continuation)
Comment on attachment 556291 [details] [diff] [review]
avoid null deref

So, Peter agrees with me, that a null showing up here is a violation of some basic CC invariant, so things are probably haywire anyways.  He is suspicious of the nsDeque, so maybe we'll try out the JS queue for a few weeks to see if that helps this.
Attachment #556291 - Flags: review?(continuation) → review-
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 500105
You need to log in before you can comment on or make changes to this bug.