Closed Bug 682616 Opened 13 years ago Closed 13 years ago

Crash, null pointer deref [@ nsCycleCollector::MarkRoots ]

Categories

(Core :: XPCOM, defect)

All
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 622411

People

(Reporter: bjacob, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

Oops, wrong bug. Ignore comment 1, sorry.
No longer blocks: 646574
Severity: normal → critical
Keywords: crash, topcrash
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=nsCycleCollector::MarkRoots says this is a low-volume crash that has been around since 3.6 but it seems to be Linux-specific with this particular signature.

Cycle collector isn't JS though, I think it belongs into XPCOM, but mmcr8 probably knows more.
Yup, XPCOM.  This looks like Bug 531961 and Bug 622411 to me.  It is just showing up differently in the call stacks on Linux, I guess.  I'll add that signature. Overall, about half of them show up as null-pointer derefs.  These crashes have been around for a few years, but we've never had any kind of reproducible test case.
Assignee: general → nobody
Status: NEW → RESOLVED
Closed: 13 years ago
Component: JavaScript Engine → XPCOM
QA Contact: general → xpcom
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.