Closed Bug 682639 Opened 8 years ago Closed 8 years ago

can't open attachment from compose window

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(thunderbird8+ fixed, thunderbird9+ fixed)

VERIFIED FIXED
Thunderbird 10.0
Tracking Status
thunderbird8 + fixed
thunderbird9 + fixed

People

(Reporter: u314746, Assigned: squib)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

when composing a mail, attached a .jpg, right-click-menu to "open" and nothing happens.


Actual results:

nothing.  Neither did the file open in a viewer nor an error message


Expected results:

I expected the file to open in a viewer.  Checked tools/options/attachments and their is a program associated with .jpg
Anything in Tools -> Error  console ?

Does it also happens in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode)?
There were no errors or messages in the console.  It still occurred in safe mode.

Ludovic, there were some errors in the safe mode page you referenced (serious: doesn't tell how to get to safe mode, lesser: typos).  Who should I notify?
(In reply to Friend of the Penguins from comment #2)
> There were no errors or messages in the console.  It still occurred in safe
> mode.

Yep thanks confirming with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0a2) Gecko/20110924 Thunderbird/8.0a2.
 
> Ludovic, there were some errors in the safe mode page you referenced
> (serious: doesn't tell how to get to safe mode, lesser: typos).  Who should
> I notify?

rtanglao@mo
Status: UNCONFIRMED → NEW
Component: General → Message Compose Window
Ever confirmed: true
QA Contact: general → message-compose
Is this limited to .jpg? The current summary needs more details...
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 6 → Trunk
It opened up several other types successfully.

I then changed .jpg options from photoviewer (default) to "always ask" and it then asked me what to do with the .jpg.  Changed it back to photoviewer and now it works, restarted a time or two and it currently opens as expected.
user on XP uses this frequently but is now seeing this problem on beta (8) channel.  it worked earlier today and claims she has not restarted thunderbird.  .docs files

I see this using trunk on win7, multiple files types. nothing in error console.
Summary: can't open attachment → can't open attachment from compose window
There was something I think Mark or David is currently fixing on a similar bug about pdf attachments not opening, related to insufficient mime types received by other mailers and how we process those things. Maybe that fix will fix this too. Don't have time for details, sorry.
(In reply to Thomas D. from comment #7)
> There was something I think Mark or David is currently fixing on a similar
> bug about pdf attachments not opening, related to insufficient mime types
> received by other mailers and how we process those things. Maybe that fix
> will fix this too. Don't have time for details, sorry.

but that's a very old bug - bug 459474 from https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=anywordssubstr&list_id=1475110&field0-0-0=assigned_to&type0-0-1=substring&field0-0-1=keywords&type1-0-1=anywordssubstr&resolution=---&value1-0-1=mime%20attach&classification=Client%20Software&classification=Components&query_format=advanced&value1-0-0=pdf%20mime&type0-0-0=anywordssubstr&value0-0-0=standard8%20bienvenu&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=component
It would be extremely helpful if someone could figure out when this broke (my money's on something from mozilla-central), since it works in 7.0.
警告: reference to undefined property Components.interfaces.nsIDOMWindowInternal
ソースファイル: chrome://messenger/content/messengercompose/MsgComposeCommands.js
行: 3236

Regression window,
Works:
http://hg.mozilla.org/comm-central/rev/8d55529ca563
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110715 Thunderbird/8.0a1 ID:20110715030021
Fails:
http://hg.mozilla.org/comm-central/rev/aa2bf01bdb8e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110716 Thunderbird/8.0a1 ID:20110716030023
Pushlog:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=8d55529ca563&tochange=aa2bf01bdb8e

Triggered by:
Bug 670235 - Remove nsIDOMWindowInternal
Recent comm-central
http://mxr.mozilla.org/comm-central/source/mail/components/compose/content/MsgComposeCommands.js#3219

3217   getInterface: function(iid)
3218   {
3219     if (iid.equals(Components.interfaces.nsIDOMWindowInternal))
3220       return window;
3221     else
3222       return this.QueryInterface(iid);
3223   },
Here's a one-line fix and a slightly-more-than-one-line test to ensure that this works.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #567628 - Flags: review?(dbienvenu)
We currently have nsIDOMWindowInternal around for compat.. Up to you if you want to keep supporting it here
So if this is a regression in 8, we should be tracking that.
Attachment #567628 - Flags: review?(dbienvenu) → review+
Due to the current closed trunk, and the fact we'd like to ship this in a beta for some testing, I've landed this directly on comm-beta:

http://hg.mozilla.org/releases/comm-beta/rev/91e7543bf9f1

Setting flag appropriately, we'll still need to land on central and aurora.
Attachment #567628 - Flags: approval-comm-aurora?
Checked in on central: http://hg.mozilla.org/comm-central/rev/9dc9ef78f28b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
thanks!
verified in trunk and 8.0b3.
Status: RESOLVED → VERIFIED
Attachment #567628 - Flags: approval-comm-beta+
Attachment #567628 - Flags: approval-comm-aurora?
Attachment #567628 - Flags: approval-comm-aurora+
Duplicate of this bug: 675740
I did flag this up over in bug 675740, just glad it got picked up eventually.
You need to log in before you can comment on or make changes to this bug.