Under some circumstances, tabindex="1" fails to make <img> keyboard navigatable

RESOLVED DUPLICATE of bug 759922

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 759922
6 years ago
5 years ago

People

(Reporter: Leif Halvard Silli, Unassigned)

Tracking

6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 556435 [details]
Test page containing <img tabindex=1 src=foo >

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

1. Open a test page with an <img> which has tabindex="1" set
2. Press the tabulator key


Actual results:

Firefox moved focus to the address bar


Expected results:

Firefox should have given focus to the img element
(Reporter)

Updated

6 years ago
Attachment #556435 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 1

6 years ago
Sorry. This seems to be an, perhaps extension initiated (e.g. Pentadactyl or Vimperator) error only in own copy of Firefox. Verified that it works as expected both on Mac OS X and under Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
(In reply to Leif Halvard Silli from comment #1)

I have reset my Firefox installation, in every possible way, including reinstalled and tried other language versions. And it remains that, on my mac - but not the mac of my neighbor, Firefox won't set focus to the img element of the test file. If someone can give other clues about on earth could cause this, then it would be great. Is there some hidden Firefox setting that I may have forgotten to delete?

Btw, I also have Camino on my computer, and it works fine there.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: tabindex="1" fails to make <img> keyboard navigatable → Under some circumstances, tabindex="1" fails to make <img> keyboard navigatable
Added as dup of a more recent bug just to eliminate copies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759922
You need to log in before you can comment on or make changes to this bug.