Add blacklist for usernames

VERIFIED FIXED in 2011-12-13

Status

support.mozilla.org
Users and Groups
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: atopal, Assigned: timw)

Tracking

unspecified
2011-12-13

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Every once in a while people try to register with inappropriate user names like fuckYou. That's rather disheartening for our volunteer contributors. We should stop them from registering with those user names. There is a list from Google that we can probably start with: https://gist.github.com/1112488

Comment 1

6 years ago
Dupe of bug 481954?
Not exactly, consider this one part of that bug, but all Eric's concerns in bug 481954 comment 2 are still valid. Need to be careful here.
(Assignee)

Updated

6 years ago
Assignee: nobody → timw
(Assignee)

Comment 3

6 years ago
How thorough should this be?
1) hardcode a list
2) pull a bigger list from file
3) the above, then run it through the permutations on symbols and common alt chars (ex. 'badword' 'b.a.d.w.o.r.d' 'b@dw0rd')


http://thedailywtf.com/Articles/The-Clbuttic-Mistake-.aspx
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 4

6 years ago
Please only compare to the linked list. 
The special wording for the error message:

The user name you entered is inappropriate. Please pick another and consider that our helpers are other Firefox users just like you.
(Assignee)

Comment 5

6 years ago
https://github.com/jsocol/kitsune/compare/589e769...69b292e
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Target Milestone: 2011Q4 → 2011-12-13
Verified a random selection from the list all triggered the 'inappropriate' message correctly
Status: RESOLVED → VERIFIED
(Reporter)

Updated

6 years ago
Duplicate of this bug: 481954
You need to log in before you can comment on or make changes to this bug.