"Use hardware acceleration when available" setting does nothing

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: FanFan Huang, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2015-08-25])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Disabled the checkbox "Use hardware acceleration when available"


Actual results:

No noticeable drop in GPU load suggestion hardware acceleration was still being used.

On firefox 6 there's a pronounced decrease in GPU load followed by less heat generated by the card.

On firefox 7 disabling the checkbox the GPU (ATI HD 5870) behaves as if it's left on temperatures are a give away.

I rolled back to Firefox 6 and immediately noticed the change between firefox 6 vs 7


Expected results:

GPU 3D acceleration was no longer used for rendering.

On high powered GPU's activating acceleration causes the GPU fan to spin up from idle.
Please post the output of about:support (only the graphic section) with FF7, disabled hwa option and after a Firefox restart.
(Reporter)

Comment 2

7 years ago
Adapter Description:ATI Radeon HD 5800 Series
Vendor ID:1002
Device ID:6898
Adapter RAM:1024
Adapter Drivers:aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version:8.881.0.0
Driver Date:7-28-2011
Direct2D Enabled:false
DirectWrite Enabled:false (6.1.7601.17563)
ClearType Parameters:Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 
WebGL Renderer:Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows:0/1

The about:support screen states the acceleration is disabled however if you keep the ATI gpu state monitor (built in to catalyst control center performance AMD overdrive) open you will notice that the GPU clock goes from idle (175Mhz to 850Mhz) if you scroll any firefox window up and down. This never occured with firefox 6 and GPU acceleration disabled.

It seems to do this more often when dealing with javascript windows (gmail causes this spike always)

Comment 3

6 years ago
I've got a theory why this bug is still unconfirmed.

I just updated to 7.0 release and now experiencing high GPU fan speed while scrolling. Never experienced it before with previous versions so hwa was probably on by default with those previous versions. Tried turning off hwa, same fan noise like what FanFan Huang describes. Gmail and this site I experience it, but curiously not pages like yahoo answers. It's noticeable when you click "in" the scroll wheel and then move the entire mouse (slowly) to scroll. 

Perhaps something else new related to 7 and not hwa is causing more fan speed.

Updated

6 years ago
Component: Preferences → Graphics
Product: Firefox → Core
QA Contact: preferences → thebes
Did you restart firefox 7 after trying to disable HWA?

Comment 5

6 years ago
Same here - Firefox 7, Windows 7 64bit, 6870 latest Catalyst 11.9.

Scrolling and rendering certain pages makes GPU temps and clocks spike for extended periods. Disabling hardware acceleration makes no difference. about:config shows it's disabled, but I still get high GPU clocks and temps at 45C. I have been disabling HWA to deal with this problem, but in 7 it won't disable.

In IE9, my browsing and scrolling temp is 36C. nVidia apparently recently released a fixed driver for high temps during scrolling. See here for details:

http://www.rage3d.com/board/showthread.php?t=33983045

Comment 6

6 years ago
@Bas Schouten, yes.

However, I've established FF7 is solely at fault; I just experimented downgrading to 6.0 and the fan issue has stopped entirely without any other change. And yes, hwa is ON by default - no fan noise.

Obviously this is not a permanent solution for me. I believe I've read that the "smooth" scrolling in FF7 is labeled as a "feature," but there are enough people commenting on this that I think warrants at least a change of limiting the scrolling FPS in the next release. I can also confirm no fan noise in IE9 as well.

I myself don't notice an appreciable "smoothness" in the scrolling and I really do believe an extra 9°c in GPU temp while simply "scrolling" is something to be changed.

Comment 7

6 years ago
What about Firefox8 or later Nightlies (up to 11)?

Also, can't it be that Windows 7 Aero is accelerating the scrolling automatically, even when Firefox HW acceleration is disabled?

Also it could just be a driver decision to increase the frequency when the card is utilized. Can you choose some powersaving profile instead of "ondemand" when you rather want lower temp than speed?

Comment 8

6 years ago
@:aceman,
FF8 - no change. Haven't experimented with further betas yet. I did switch from Aero to a windows "classic" theme which DID in fact solve the fan noise. But remember this all started with FF7's new implementation of the canvas graphic rendering system.

I would say that if the scrolling FPS can't be limited in the next release, then at least have the "disable hwa" option limit the fan speed since it is the rendering system in FF that tell the windows system drivers to increase the GPU clocks when scrolling. I think the band-aide solution of lowering your power scheme in windows isn't going to hold up because you would constantly need to change it if you decide to play 3D gaming.

Remember, this is still a firefox issue - which all started with the release of FF7.

Comment 9

6 years ago
Want to add to this that still on Firefox 12 this issue exists 

Heres a link to a page going back to Firefox 8 and lists many other instances of this problem. http://forums.mozillazine.org/viewtopic.php?f=7&t=2361245

Please fix this bug its bad enough having the lack of "Bookmark This Tab" on the tab context menu since firefox 4 but now that Firefox 3.6 is unsupported I have no choice but to upgrade and this hardware acceleration issue is a royal pain that I can't fix with an extension like I can with the tab issue.

Updated

6 years ago
Summary: Firefox 7 Beta 2: "Use hardware acceleration when available" setting does nothing → "Use hardware acceleration when available" setting does nothing
Version: 7 Branch → 12 Branch

Comment 10

3 years ago
780 gtx
340.52 driver
on 377.88  and   firefox 31 and lower version 
worked 3 monts without hardlock and freeze

Updated to 32 firefox.
hardlocks.Freeze. GPU Cooler worked in freezed state at max.
Only  when scrolling. In random moment
But mostly in sites with big pictures

Comment 11

3 years ago
FanFan, do you still see this problem? 
And (from comment #4) Did you restart firefox 7 after trying to disable HWA?
Flags: needinfo?(kaboom05)
Whiteboard: [closeme 2015-08-25]
(Reporter)

Comment 12

3 years ago
No I do not observer this problem anymore you can close this now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kaboom05)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.