:target CSS selector is not updated when navigating back

RESOLVED DUPLICATE of bug 680257

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 680257
6 years ago
6 years ago

People

(Reporter: Yves Goergen, Unassigned)

Tracking

6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

303 bytes, text/plain
Details
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Create a page with several Elements with an id attribute, and some links that jump to another id element. The id elements have a CSS definition with the :target selector to highlight the currently selected one. When navigating forward, another element is highlighted. When navigating back, the previously highlighted element is not highlighted again, but the style just stays the same, as if I had not navigated back.



Expected results:

Instead, the style should correctly represent the page at any time. (Hard to explain...)

Comment 1

6 years ago
Please attach a reduced testcase, or supply a URL to a web page, that demonstrates the problem.
(Reporter)

Comment 2

6 years ago
Created attachment 556654 [details]
Testcase

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 680257
(Reporter)

Comment 4

6 years ago
Thanks for fixing it after all.

But why does the Bugzilla search never find such things?
(In reply to Yves Goergen from comment #4)
> But why does the Bugzilla search never find such things?

Some things the world may never know.

You might want to try searching with Google (this works only as of recently).  For instance, "site:bugzilla.mozilla.org :target back" finds the bug in the 4th hit, despite Google not understanding that ':target' is different from 'target'.
You need to log in before you can comment on or make changes to this bug.