Closed Bug 682974 Opened 10 years ago Closed 10 years ago

crash nsTHashtable

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 548685

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-7a32aa0e-c3a3-433a-a174-31dce2110829 .
============================================================= 

Seen while reviewing crash stats. https://crash-stats.mozilla.com/report/list?signature=nsTHashtable%3CnsBaseHashtableET%3CnsURIHashKey,%20nsCOMPtr%3CnsIStorageStream%3E%20%3E%20%3E::s_HashKey%28PLDHashTable*,%20void%20const*%29. Heavier concentration in 7.0. 

https://crash-stats.mozilla.com/report/index/7a32aa0e-c3a3-433a-a174-31dce2110829

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsURIHashKey,nsCOMPtr<nsIStorageStream> > >::s_HashKey 	obj-firefox/dist/include/nsTHashtable.h:365
1 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:615
2 	xul.dll 	mozilla::places::History::UnregisterVisitedCallback 	toolkit/components/places/History.cpp:1804
3 	xul.dll 	mozilla::dom::Link::UnregisterFromHistory 	
4 	xul.dll 	mozilla::dom::Link::~Link 	content/base/src/Link.cpp:67
5 	xul.dll 	nsHTMLLinkElement::~nsHTMLLinkElement 	content/html/content/src/nsHTMLLinkElement.cpp:142
6 	xul.dll 	nsHTMLLinkElement::`vector deleting destructor' 	
7 	xul.dll 	nsNodeUtils::LastRelease 	
8 	xul.dll 	nsGenericElement::Release 	content/base/src/nsGenericElement.cpp:4382
9 	xul.dll 	nsCycleCollector::CollectWhite 	xpcom/base/nsCycleCollector.cpp:2025
10 	xul.dll 	nsCycleCollector::FinishCollection 	xpcom/base/nsCycleCollector.cpp:2838
11 	xul.dll 	nsCycleCollectorRunner::Collect 	xpcom/base/nsCycleCollector.cpp:3526
12 	xul.dll 	nsCycleCollector_collect 	xpcom/base/nsCycleCollector.cpp:3592
13 	xul.dll 	nsJSContext::CycleCollectNow 	dom/base/nsJSEnvironment.cpp:3187
14 	xul.dll 	CCTimerFired 	dom/base/nsJSEnvironment.cpp:3227
15 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:424
16 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:520
17 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
18 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
19 	xul.dll 	xul.dll@0xbb992b 	
20 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
21 	xul.dll 	_SEH_epilog4 	
22 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
23 	xul.dll 	mozilla::storage::AsyncExecuteStatements::AsyncExecuteStatements 	storage/src/mozStorageAsyncStatementExecution.cpp:239
24 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
25 		@0x20bb6ef 	
26 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:224
27 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
28 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
29 	firefox.exe 	firefox.exe@0x4033 	
30 	firefox.exe 	__tmainCRTStartup 	crtexe.c:594
31 	firefox.exe 	_SEH_epilog4 	
32 	kernel32.dll 	BaseThreadInitThunk 	
33 	ntdll.dll 	__RtlUserThreadStart 	
34 	kernel32.dll 	LoadStringByReference 	
35 	kernel32.dll 	LoadStringByReference
This looks very much like the stack in bug 548685, so it might be better
to add the signature there and dupe it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548685
You need to log in before you can comment on or make changes to this bug.