If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

License boilerplate should be served as text/plain

RESOLVED FIXED in 4.3

Status

www.mozilla.org
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Mook (work), Assigned: jlongster)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r=96799 b=trunk, URL)

(Reporter)

Description

6 years ago
The various license boilerplate templates are being served as text/html instead of text/plain, losing formatting (and in the case of the <-- --> [sic] one, being completely invisible).

Comment 1

6 years ago
I bet this is related to the recent merge.  There seems to be a general issue sending out non .html files (such as .xml and .pdf).  Assigning to James.
Assignee: nobody → jlong
(Assignee)

Comment 2

6 years ago
Yes, the mozilla.org pages are loaded in a special way which loses some of Apache's goodness. We've been able to patch everything up to make it work mostly, but there will be small things like this. Easily fixable, just hard to find.

I dislike having the patch things up this way, but we did a lot of research on how to do the merge and every solution had its downsides. This was the least troublesome out of them.
Target Milestone: --- → 3.9
Duplicate of this bug: 684385

Updated

6 years ago
Duplicate of this bug: 685375
So, what's the status here?  It's been about a month with no action, and this bug is pretty annoying to those of us who use these templates.  Would be nice to see it fixed soon. :-)
(Assignee)

Comment 6

6 years ago
Sorry about the wait, been trying to catch up with things for a while. I'll fix it this week.
Target Milestone: 3.9 → 3.12

Comment 7

6 years ago
I forgot how long weeks are in the states. I'm used to the 7-day week they use in Asia.
(Assignee)

Comment 8

6 years ago
Somehow it didn't get moved to the next milestone. Apologies. There's a lot on our plate.

should be fixed in r96637. Please test on www-dev.allizom.com.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 3.12 → 4.3
(Assignee)

Comment 9

6 years ago
Is it fixed?
(In reply to James Long (:jlongster) from comment #8)
> should be fixed in r96637. Please test on www-dev.allizom.com.
[...]
> Is it fixed?

www-dev.allizom.com doesn't exist, but .org does, and it does seem to be fixed there.

That is -- the links on this page:
  http://www-dev.allizom.org/MPL/boilerplate-1.1/
appear to be served as text/plain (they're line-broken correctly).

The "www.mozilla.org" version is still incorrect, but I assume that's just because r96637 hasn't made it to production yet.
(Assignee)

Comment 11

6 years ago
Yep, it should work now on production.

pushed to production r96795
Verified fixed on production. Thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

6 years ago
There was a bug in the code and it served some other pages as text/plain when it should have. I reverted it on production and fixed it in r96799.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: r=96799 b=trunk
(Assignee)

Comment 14

6 years ago
This page was served as text/plain before, but is fixed:

https://www-dev.allizom.org/about/mission.html

This one is still working:

https://www-dev.allizom.org/MPL/boilerplate-1.1/mpl-tri-license-html

I think my last patch is good. Marking QA though.
Keywords: qawanted
(Assignee)

Comment 15

6 years ago
QA signed off in IRC.

pushed to production r96801
Keywords: qawanted
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.