Last Comment Bug 683171 - make -C browser/install on cross compiler is always failed
: make -C browser/install on cross compiler is always failed
Status: RESOLVED FIXED
fixed-in-bs
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: ---
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 673711 (view as bug list)
Depends on:
Blocks: 655678
  Show dependency treegraph
 
Reported: 2011-08-30 08:40 PDT by Makoto Kato [:m_kato]
Modified: 2011-09-15 19:17 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Properly disable GENERATE_CACHE when cross compiling (1.01 KB, patch)
2011-08-30 08:47 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-08-30 08:40:59 PDT
this is a regression of bug 655678.  Since GENRATE_CACHE is 1 on cross, make -C browser/installer is always failed.

cd ../../dist && (cd firefox && rm -f omni.jar components/binary.manifest && grep -h '^binary-component' components/*.manifest > binary.manifest ; for m in components/*.manifest; do sed -e 's/^binary-component/#binary-component/' $m > tmp.manifest && mv tmp.manifest $m; done; /usr/bin/zip -r9m omni.jar chrome chrome.manifest components/*.js components/*.xpt components/*.manifest modules res defaults greprefs.js jsloader  -x chrome/icons/\* defaults/pref/channel-prefs.js res/cursors/\* res/MainMenu.nib/\*  && 1 && /usr/bin/python2.6 /home/makoto/Development/hg.mozilla.org/mozilla-arm/config/optimizejars.py --optimize /home/makoto/Development/hg.mozilla.org/objdir-arm/browser/installer/../../jarlog//en-US ./ ./ && mv binary.manifest components && printf "manifest components/binary.manifest\n" > chrome.manifest) && (cd firefox && /usr/bin/python2.6 /home/makoto/Development/hg.mozilla.org/mozilla-arm/config/createprecomplete.py) && tar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f - firefox | bzip2 -vf > firefox-9.0a1.en-US.linux-gnueabi-arm.tar.bz2

...
  adding: defaults/pref/services-sync.js (deflated 76%)
  adding: defaults/pref/firefox.js (deflated 75%)
  adding: greprefs.js (deflated 73%)
/bin/sh: 1: not found
make[1]: *** [make-package] Error 127
make[1]: Leaving directory `/home/makoto/Development/hg.mozilla.org/objdir-arm/browser/installer'
Comment 1 Mike Hommey [:glandium] 2011-08-30 08:47:29 PDT
Created attachment 556859 [details] [diff] [review]
Properly disable GENERATE_CACHE when cross compiling
Comment 2 Mike Hommey [:glandium] 2011-08-30 08:57:54 PDT
http://hg.mozilla.org/projects/build-system/rev/3edb52f6710d
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-31 08:09:56 PDT
http://hg.mozilla.org/mozilla-central/rev/3edb52f6710d
Comment 4 Makoto Kato [:m_kato] 2011-09-01 09:27:30 PDT
This fix is incorrect.  Build error still occurs.   Please set true instead of empty string.


Compressing...
cd ../../dist && (cd firefox && rm -f omni.jar components/binary.manifest && grep -h '^binary-component' components/*.manifest > binary.manifest ; for m in components/*.manifest; do sed -e 's/^binary-component/#binary-component/' $m > tmp.manifest && mv tmp.manifest $m; done; /usr/bin/zip -r9m omni.jar chrome chrome.manifest components/*.js components/*.xpt components/*.manifest modules res defaults greprefs.js jsloader  -x chrome/icons/\* defaults/pref/channel-prefs.js res/cursors/\* res/MainMenu.nib/\*  &&  && /usr/bin/python2.6 /home/makoto/Development/hg.mozilla.org/mozilla-arm/config/optimizejars.py --optimize /home/makoto/Development/hg.mozilla.org/objdir-arm/browser/installer/../../jarlog//en-US ./ ./ && mv binary.manifest components && printf "manifest components/binary.manifest\n" > chrome.manifest) && (cd firefox && /usr/bin/python2.6 /home/makoto/Development/hg.mozilla.org/mozilla-arm/config/createprecomplete.py) && tar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f - firefox | bzip2 -vf > firefox-9.0a1.en-US.linux-gnueabi-arm.tar.bz2
/bin/sh: Syntax error: "&&" unexpected
make[1]: *** [make-package] Error 2
make[1]: Leaving directory `/home/makoto/Development/hg.mozilla.org/objdir-arm/browser/installer'
Comment 5 Mike Hommey [:glandium] 2011-09-01 09:35:41 PDT
*sigh*, the make logic:

FOO=
ifdef FOO
$(error FOO)
endif
FOO?=true

foo:
        @echo $(FOO)

make -> displays nothing.
Comment 6 Mike Hommey [:glandium] 2011-09-01 09:38:59 PDT
That behaviour is even documented:
http://www.gnu.org/software/make/manual/make.html#Flavors

Note that a variable set to an empty value is still defined, so ‘?=’ will not set that variable.
Comment 7 Mike Hommey [:glandium] 2011-09-01 09:43:12 PDT
http://hg.mozilla.org/projects/build-system/rev/61dc35b8f63f
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-02 14:49:08 PDT
http://hg.mozilla.org/mozilla-central/rev/61dc35b8f63f
Comment 9 Ed Morley [:emorley] 2011-09-02 20:48:44 PDT
The whole b-s merge backed out of m-c for causing bustage:
http://hg.mozilla.org/mozilla-central/rev/472716252ea3

https://tbpl.mozilla.org/?usebuildbot=1&rev=e5815c156b6c
Comment 10 Stefan 2011-09-03 00:55:58 PDT
*** Bug 673711 has been marked as a duplicate of this bug. ***
Comment 11 Mike Hommey [:glandium] 2011-09-05 09:01:15 PDT
I backed out the back out on b-s.

Note You need to log in before you can comment on or make changes to this bug.