bad location of the user files

VERIFIED DUPLICATE of bug 60182

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 60182
17 years ago
2 years ago

People

(Reporter: Sam Steingold, Assigned: matt)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.7) Gecko/20010109
BuildID:    2001010901

my user preferences prefs.js &c are located in
C:\Program
Files\Netscape\Users50\sds\kyxfxk51.slt\mjgqyx89.slt\1t89vl74.slt\auubw6mj.slt\mla2fchh.slt\6haxezub.slt
and there appears to be no way to move them to a more regular location, like
C:\Program Files\Netscape\Users50\sds\


Reproducible: Always
Steps to Reproduce:
create a new profile.
files are created in
C:\Program Files\Netscape\Users50\sds\kyxfxk51.slt\mjgqyx89......
move the files to
C:\Program Files\Netscape\Users50\sds\
the stupid kyxfxk51.slt... are re-created.

Actual Results:  many levels of directories with strange names were created

Expected Results:  I expect the location of my prefs.js to be reasonable.
looks like bug 60799, which in turn was a dup of bug 60182.

*** This bug has been marked as a duplicate of 60182 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Preferences → Profile Manager BackEnd
Resolution: --- → DUPLICATE

Comment 2

17 years ago
in fact this is a duplicate/result of bug 56002
Make path to profile dir unpredictable

yes we should definitely not continuously salt salted directory names...
URL: n/a
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
this means that I have no control as to where prefs.js go.
interesting.
so how am I supposed to backup it?
can I disable this *.slt nightmare?
thanks.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.