Closed Bug 683324 Opened 8 years ago Closed 8 years ago

crash js::types::TypeSet::addType loading Hotmail Calendar

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 683317

People

(Reporter: xtc4uall, Unassigned)

References

()

Details

(Keywords: crash, regression)

This bug was filed from the Socorro interface and is 
report bp-ad06cee6-87e5-412e-8ca2-d44a12110830 .
============================================================= 

Frame 	Module 	Signature 	Source
0 		@0x9f1ea71 	
1 	mozjs.dll 	js::types::TypeSet::addType(JSContext*,js::types::Type) 	js/src/jsinferinlines.h:1009
2 	mozjs.dll 	js::mjit::EnterMethodJIT(JSContext*,js::StackFrame*,void*,js::Value*,bool) 	js/src/methodjit/MethodJIT.cpp:884
3 	mozjs.dll 	js::mjit::JaegerShot(JSContext*,bool) 	js/src/methodjit/MethodJIT.cpp:961
4 	mozjs.dll 	js::Interpret(JSContext*,js::StackFrame*,js::InterpMode) 	js/src/jsinterp.cpp:4237
5 	mozjs.dll 	js::types::TypeScript::SetThis(JSContext*,JSScript*,js::types::Type) 	js/src/jsinferinlines.h:615
6 	mozjs.dll 	js::ExecuteKernel(JSContext*,JSScript*,JSObject&,js::Value const&,js::ExecuteType,js::StackFrame*,js::Value*) 	js/src/jsinterp.cpp:941
7 	mozjs.dll 	js::Execute(JSContext*,JSScript*,JSObject&,js::Value*) 	js/src/jsinterp.cpp:977
8 	mozjs.dll 	EvaluateUCScriptForPrincipalsCommon(JSContext*,JSObject*,JSPrincipals*,wchar_t const*,unsigned int,char const*,unsigned int,unsigned __int64*,JSVersion) 	js/src/jsapi.cpp:4933
9 	mozjs.dll 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:4945
10 	xul.dll 	nsJSContext::EvaluateString(nsAString_internal const&,void*,nsIPrincipal*,char const*,unsigned int,unsigned int,nsAString_internal*,int*) 	dom/base/nsJSEnvironment.cpp:1465
11 	xul.dll 	nsScriptLoader::EvaluateScript(nsScriptLoadRequest*,nsString const&) 	content/base/src/nsScriptLoader.cpp:906
12 	xul.dll 	nsScriptLoader::ProcessRequest(nsScriptLoadRequest*) 	content/base/src/nsScriptLoader.cpp:799
13 	xul.dll 	nsScriptLoader::ProcessScriptElement(nsIScriptElement*) 	
14 	xul.dll 	nsScriptElement::MaybeProcessScript() 	content/base/src/nsScriptElement.cpp:182
15 	xul.dll 	nsHTMLScriptElement::MaybeProcessScript() 	content/html/content/src/nsHTMLScriptElement.cpp:333
16 	xul.dll 	nsHTMLScriptElement::DoneAddingChildren(int) 	content/html/content/src/nsHTMLScriptElement.cpp:260
17 	xul.dll 	nsHtml5TreeOpExecutor::RunScript(nsIContent*) 	parser/html/nsHtml5TreeOpExecutor.cpp:733
18 	xul.dll 	nsHtml5TreeOpExecutor::RunFlushLoop() 	parser/html/nsHtml5TreeOpExecutor.cpp:528
19 	xul.dll 	nsHtml5ExecutorReflusher::Run() 	parser/html/nsHtml5TreeOpExecutor.cpp:91
20 	xul.dll 	nsThread::ProcessNextEvent(int,int*) 	xpcom/threads/nsThread.cpp:631
21 	nspr4.dll 	_MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
22 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:110
23 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:201
24 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:175
25 	xul.dll 	nsBaseAppShell::Run() 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
26 	xul.dll 	xul.dll@0xbba973 	
27 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp:224
28 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
29 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
30 	firefox.exe 	firefox.exe@0x4033 	
31 	firefox.exe 	__tmainCRTStartup 	crtexe.c:594
32 	firefox.exe 	_SEH_epilog4 	
33 	kernel32.dll 	BaseProcessStart 	
34 	kernel32.dll 	GetCodePageFileInfo 	
35 	kernel32.dll 	BaseProcessStart 	
36 	firefox.exe 	pre_c_init 	crtexe.c:304 

Probably TI related.
Marcia beat me by some Minutes, but saw my Hotmail Calender Comment when reporting above Stacklog =)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 683317
You need to log in before you can comment on or make changes to this bug.