On login from main page, I get an editor page for "en-US"

VERIFIED FIXED in 1.1

Status

Mozilla Developer Network
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Janet Swisher, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: c=bug u=visitor p=1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 557020 [details]
screenshot showing the problem

Steps to reproduce:

1. Type "developer.mozilla.org" in the browser address bar. MDN redirects me to "https://developer.mozilla.org/en-US/".
2. Click "Log in".
3. Enter user ID and password and click "log in".

Expected result: Main page, with user link in header. 

Actual result: Empty editor page for "en-US", with "([MISSING: page.tags.save-page])" in the tags area.

Note: If I then click the MDN logo in the header, I get the expected result.

Updated

6 years ago
Duplicate of this bug: 683348
This is a problem with the rewrite rules for Apache; there is no -- and should be no -- /en-US/ page on the wiki. This should be routing to Django.
Whiteboard: c=bug u=visitor p=1
Target Milestone: --- → 1.1
Assignee: nobody → lcrouch
Go to https://developer-stage9.mozilla.org/en-US

should be redirect to

https://developer-stage9.mozilla.org/en-US/

instead of seeing an edit page for en-US
Assignee: lcrouch → mozbugs.retornam
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → FIXED
and of course, after you login you'll be sent to the correct landing page.
Would also love to see a test for this (wish I could flag this bug!)
qa-verified https://developer-stage9.mozilla.org/en-US/
Keywords: qawanted
verified fixed https://developer.mozilla.org/en-US/
Status: RESOLVED → VERIFIED
Assignee: mozbugs.retornam → nobody
(Assignee)

Updated

5 years ago
Version: Deki → unspecified
(Assignee)

Updated

5 years ago
Component: Deki Infrastructure → Other
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.