Improve UI of "Delete or Distrust" functionality in authorities tab of certificate manager

RESOLVED DUPLICATE of bug 345934

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 345934
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In the "Authorities" Tab of the Certificate Manager, it is possible to "Delete or Distrust" a CA. Hitting this button removes the CA from the list, even if it is a built-in CA (such as the DigiTrust CA was). After reopening the tab, the entry is back (of course, no trust bits are set, but there is no visual difference).

This seems to have confused quite a few people that thought, their manual removal of the CA was unsuccessful. This is supported by the fact that the UI in fact removes the entry first, and it pops up again only after reopening the tab.

I suggest two things here:

1) When deleting/distrusting, don't remove the entry at all if it is built-in and cannot be removed therefore.

2) Make entries that have no trust bits set visually different from the rest (e.g. make them greyed out).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345934
You need to log in before you can comment on or make changes to this bug.