Last Comment Bug 683624 - Get xhydra to work with gcc 4.6
: Get xhydra to work with gcc 4.6
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Joshua Cranmer [:jcranmer]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 09:42 PDT by Joshua Cranmer [:jcranmer]
Modified: 2011-09-03 11:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: Build on both 4.5 and 4.6 (1.20 KB, patch)
2011-08-31 09:42 PDT, Joshua Cranmer [:jcranmer]
taras.mozilla: review+
Details | Diff | Splinter Review
Part 2: Fix up decl_name in gcc 4.6 (748 bytes, patch)
2011-08-31 09:44 PDT, Joshua Cranmer [:jcranmer]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Joshua Cranmer [:jcranmer] 2011-08-31 09:42:00 PDT
Created attachment 557214 [details] [diff] [review]
Part 1: Build on both 4.5 and 4.6
Comment 1 Joshua Cranmer [:jcranmer] 2011-08-31 09:44:32 PDT
Created attachment 557217 [details] [diff] [review]
Part 2: Fix up decl_name in gcc 4.6

It turns out that TRANSLATION_UNIT_DECL is added as a context for gcc 4.6 globals, which causes a D_1:: to prefix global names. (The `D' for "I don't know what this is", `1' for "it has UID 1")
Comment 2 (dormant account) 2011-08-31 14:25:58 PDT
Comment on attachment 557217 [details] [diff] [review]
Part 2: Fix up decl_name in gcc 4.6

Is there a testcase for this?
Comment 3 Joshua Cranmer [:jcranmer] 2011-08-31 16:27:42 PDT
Around 5 or 6 of the treehydra test cases are testing this (this is what caused treehydra failure with gcc 4.6).
Comment 4 Joshua Cranmer [:jcranmer] 2011-09-03 11:18:45 PDT
Pushed to the dehydra repository.

Note You need to log in before you can comment on or make changes to this bug.