Closed Bug 683629 Opened 10 years ago Closed 3 days ago

TI: performance regression on the Dromaeo eval tests

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: bzbarsky, Assigned: bhackett1024)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: js-triage-needed)

http://dromaeo.com/?id=148654,148653 is pre-TI-landing vs post-TI-with-closure-fix.  The |new Function| thing got a bit slower; eval() got 2x slower.

It's not clear why this is happening, esp. for eval().
Keywords: regression
We need to get this triaged at the very least.
Assignee: general → bhackett1024
Whiteboard: js-triage-needed
After 2 years, and the engine changes, this bug shouldn't be about the regression anymore (I guess).
Comparing the results with Chrome, Firefox is 4,44x faster on "Normal eval".
But on "new Function" Chrome is 4,1x faster.
http://dromaeo.com/?id=203814,203815
The problem is https://bugzilla.mozilla.org/show_bug.cgi?id=579234 ?
Depends on: 579234
Status: NEW → RESOLVED
Closed: 3 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.