Closed Bug 683656 Opened 9 years ago Closed 5 years ago

[geolocation] "share location" should be remembered for a complete browsing session

Categories

(Core :: DOM: Geolocation, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 696283

People

(Reporter: public, Unassigned)

Details

When the user chooses to "share location" with a website, subsequent calls to getCurrentPosition() or watchPosition(), as long as the page has not been refreshed/reopen, shouldn't trigger permission prompt.

From a privacy perspective, if one "share location" is enough to allow watchPosition(), then it should be enough to allow regular calls to getCurrentPosition() or mixed calls to watchPosition() and getCurrentPosition()

Fixing this bug might fix bug 683472
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696283
You need to log in before you can comment on or make changes to this bug.