Address book permits creation of Mailing List with unusable name, e.g. 'Mailing"List' (having inner double quotes)

RESOLVED WORKSFORME

Status

Thunderbird
Address Book
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: David White, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 557280 [details]
Error shown when trying to send

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.20) Gecko/20110803 Firefox/3.6.20 ( .NET CLR 3.5.30729; .NET4.0C)
Build ID: 20110803131630

Steps to reproduce:

Using address book, create a new mailing list with the name "foo"bar" (remove surrounding quotes). The name is not rejected as bad and the list is saved.


Actual results:

Now create a new message and for the recipient enter "foo" (remove surrounding quotes). TB offers an auto-complete of "foo\"bar" (including the surrounding quotes). Accept this auto-complete. Now try to send the message. You get an error shown in the attached screen print file saying this is not a valid email format.


Expected results:

In my opinion, the mailing list name should have been edit checked and rejected as invalid rather than saved. But if it is to be accepted at all, it should work when it comes time to send using it.
Are you really still using Thunderbird 2.0.x ?
(Reporter)

Comment 2

6 years ago
Indeed. I still see no compelling reason to move. However, I do have testbeds with 3.x, 5.x, 6.x and soon 7.x for testing my addons. And I can tell you that this behavior remains.

Comment 3

6 years ago
Version                7.0
User Agent             Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20110925 Thunderbird/7.0
Application Build ID   20110925021328

I see a different result for version 7.0 .

Created a list: foo"bar with two e-mail addresses.

Composed a new e-mail and typed in: foo in the TO-field - the auto-complete action suggested: "foo\"bar" <"foo\"bar"> - accepted that.

Sending the e-mail without error messages. Received the e-mail at both addresses correctly.
(Reporter)

Comment 4

6 years ago
Thanks all. As I stated earlier today, I have no TB 7 testbed (soon perhaps). I just tested this again on TB 6 and attempts to send fail with bad email format.
still fails on 31.6.0...
"my\"list1" <"my\"list1"> is not a valid e-mail address because it is not of the form user@host. You must correct it before sending the e-mail.

...but wfm on trunk 40.0a1 (2015-04-15)

So it looks as if this was fixed by something.
This needs a test case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
See Also: → bug 170823
Summary: Address Book Permits Creation of List With Unusable Name → Address book permits creation of Mailing List with unusable name, e.g. 'Mailing"List' (having inner double quotes)
Blocks: 1156245
(In reply to Thomas D. from comment #5)

> So it looks as if this was fixed by something.
> This needs a test case.

I filed bug 1156245 for the testcase.
You need to log in before you can comment on or make changes to this bug.