Require >1 tag in common for two articles to be "related"

VERIFIED FIXED in 2011-10-18

Status

support.mozilla.org
Knowledge Base Software
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Assigned: jsocol)

Tracking

unspecified
2011-10-18

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Since SUMO-2011-08-30, the Related Articles block is not empty when the article has no topic. The Relevant To section seems to be considered as a topic.
See:
https://support.mozilla.com/en-US/kb/Plugin%20crash%20reports
https://support.mozilla.com/en-US/kb/what-are-tab-groups
https://support.mozilla.com/en-US/kb/How%20to%20set%20the%20home%20page
...
(Reporter)

Updated

6 years ago
Keywords: regression

Comment 1

6 years ago
(In reply to Scoobidiver from comment #0)
> Since SUMO-2011-08-30, the Related Articles block is not empty when the
> article has no topic. The Relevant To section seems to be considered as a
> topic.


That's correct. It is a topic. We still need to come up with other topics and assign them to articles so that we have better related articles. I decided to wait on feedback from Crystal's UX research before implementing something.

It would help to know how the related articles are picked. Why a particular 5 articles out of the troubleshooting or how-to articles.
(Assignee)

Comment 2

6 years ago
(In reply to Verdi from comment #1)
> It would help to know how the related articles are picked. Why a particular
> 5 articles out of the troubleshooting or how-to articles.

We pick the five "most" in common, that is: order the list of articles by the number of tags in common with the current article, descending, so the most tags in common is at the top. Then pick the top 5 in that list.

Now, since basically all articles have one tag in common, we have a big list of "related" articles for every article. When we pick the "top 5" out of a group that's all 1, exactly, that list gets sorted is sort of up to and an artifact of MySQL and probably related the order in which things (articles, tags) were added to the database.

We might require that articles have > 1 tag in common to be considered related, or we might do nothing and just close out this bug.
Keywords: regression
(Assignee)

Updated

6 years ago
Blocks: 687677
Summary: Related Articles block is not empty when the article has no topic → Require >1 tag in common for two articles to be "related"
(Assignee)

Updated

6 years ago
Priority: -- → P1
(Assignee)

Updated

6 years ago
Target Milestone: --- → 2011-10-11
(Assignee)

Updated

6 years ago
Assignee: nobody → james
(Assignee)

Comment 3

6 years ago
Pull req https://github.com/jsocol/kitsune/pull/261 but didn't get reviewed in time.
Target Milestone: 2011-10-11 → 2011-10-18
(Assignee)

Comment 4

6 years ago
https://github.com/jsocol/kitsune/compare/1be1edf...78636af
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified related articles display with topics.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.