Closed Bug 683728 Opened 9 years ago Closed 5 years ago

Walking the references doesn't fully work (msgWindow.openFolder is null)

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86_64
Linux
defect
Not set

Tracking

(seamonkey2.37 fixed)

RESOLVED FIXED
seamonkey2.37
Tracking Status
seamonkey2.37 --- fixed

People

(Reporter: mnyromyr, Assigned: philip.chee)

References

Details

Attachments

(1 file)

Steps to reproduce:
- set mailnews.messageid.openInNewWindow to true, so that clicking a reference will open a new standalone message window
- choose a message thread with at least three messages in one subthread, eg in a newsgroup
- open the last message of the subthread
- click its last reference: a new window opens with the message
- switch to this new window
- click its last reference: nothing happens, except an error on the Error Console:

Error: msgWindow.openFolder is null
Source File: chrome://messenger/content/mailContextMenus.js
Line: 516

This is because there is no folder pane in the standalone message window.
Using gDBView.msgFolder instead of msgWindow.openFolder should fix this.

(MXR suggests that Thunderbird is affected as well.)
> Error: msgWindow.openFolder is null
> Source File: chrome://messenger/content/mailContextMenus.js
> Line: 516
> 
> This is because there is no folder pane in the standalone message window.
> Using gDBView.msgFolder instead of msgWindow.openFolder should fix this.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8588625 - Flags: review?(mnyromyr)
Attachment #8588625 - Flags: superreview+
Attachment #8588625 - Flags: review?(mnyromyr)
Attachment #8588625 - Flags: review+
http://hg.mozilla.org/comm-central/rev/f7d719e4f89e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.37
Duplicate of this bug: 396444
You need to log in before you can comment on or make changes to this bug.