There should not be a gap between the fill and the stroke on SVG text

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Blaise Kal, Unassigned)

Tracking

7 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 557446 [details]
Testcase

Situation:
SVG with text with a large font-size and narrow stroke-width.

ER:
There is no whitespace visible between text and stroke

AR:
There is whitespace visible between text and stroke. Some tests showed that this was getting worse when using large font-sizes and narrow stroke-width's, or when using a low value for text rotation.
(Reporter)

Comment 1

7 years ago
Created attachment 557448 [details]
Rendering of the testcase

Updated

7 years ago
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
Doesn't happen on Windows. Presumably some artifact of the Mac OS Core graphics renderer. Do you see the same thing with Safari/Chrome?
(Reporter)

Comment 3

7 years ago
Testcase in a couple of browsers:

Don't have the issue:
 - Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.122 Safari/535.1
 - Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.50 (KHTML, like Gecko) Version/5.1 Safari/534.50
 - Opera/9.80 (Macintosh; Intel Mac OS X 10.6.8; U; en) Presto/2.9.168 Version/11.50
 - Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
 - Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
 - Mozilla/5.0 (X11; Linux i686; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

Have the issue:
 - Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0 
   (= browser from initial report and testcase rendering)
 - Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0 
   (even worse than on a Mac)
Would you be willing to establish a regression range? You can download builds from here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ You'd want to be looking in mozilla-central from around August this year onwards since 6.0 was OK.
(Reporter)

Comment 5

7 years ago
Just tried, Firefox 6.0 / Mac also has the issue. 
Note that Firefox 6.0 / Linux did not have the issue.

UA: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
If you download builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ you should be able to establish what day things changed. We can then use that to figure out what code change caused this.
Keywords: regressionwindow-wanted
(Reporter)

Comment 7

7 years ago
I'm sorry, I don't follow why you think this is a regression issue. Can you explain?

Firefox 4.0.1 / Mac also has the issue.
My fault I was confused by all the information about versions and platforms in your previous post.

Does turning off hardware acceleration and restarting the browser fix it for you?
Keywords: regressionwindow-wanted
(Reporter)

Comment 9

7 years ago
Unchecked Preferences > Advanced > General > Use hardware acceleration when available, restarted browser.

Did not solve the issue.
I'm not seeing this on OS X 10.8.4.
Summary: SVG whitespace leakage with stroke on text → There should not be a gap between the fill and the stroke on SVG text
(Reporter)

Comment 11

5 years ago
I can no longer reproduce in Fx 25.0b on Win7 64bit.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.