Email body blank on meeting invitation received from MS Exchange user

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: fehe, Unassigned)

Tracking

Trunk
All
Windows 7

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 557510 [details]
test case: Email exhibiting the issue

I recently received the attached email (edited to for privacy reasons), containing a meeting invitation.  The message body was completely blank with Lightning nightly enabled in Shredder nightly.  Disabling Lightning allowed the to be viewed.  Tested with most recent builds, as of this posting.

Uploading the message to Gmail, the content, including the calendar/invitation content can be viewed without issue.
Do you get any error console messages?
(Reporter)

Comment 2

7 years ago
Are you unable to reproduce this by opening the attached email?

I get the following in Error Console:

Error: An error occurred updating the button_archive command: [Exception... "'[JavaScript Error: "getIdentityForHeader(msg) is null" {file: "chrome://messenger/content/folderDisplay.js" line: 2066}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 86
--------
Error: getIdentityForHeader(msgHdr) is null
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 924
--------
Error: Components.classes['@mozilla.org/calendar/ics-service;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///D:/TBird%20Bug/display/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 163
What version / build of Thunderbird do you use? What version / build of Lightning do you use?
(Reporter)

Comment 4

7 years ago
As I mentioned in comment 0, I use Shredder nightly (9.0a1) and Lightning nightly (1.1a1pre).
(Reporter)

Comment 5

7 years ago
Figured out the causes: version confusion.  There are two Lightning nightlies and both have the exact same version number.  One is on the FTP server under http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central and the other is on the FTP server under http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly

It would be great it these are named differently and given different version numbers, as this is needlessly confusing.

Thanks
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
<https://developer.mozilla.org/en/Calendar/Calendar_Versions> links to the correct Lightning nightly builds for your Thunderbird version.
(Reporter)

Comment 7

7 years ago
Thanks.  Still would be nice to have different names/version numbers, though.
I filed bug 685528 to fix version numbers. Which nightlys have the same version?

comm-central should have 1.1a1pre
comm-aurora should (wrongly, currently) have 1.0b6pre
there is no comm-beta nightly
(Reporter)

Comment 9

7 years ago
There is also this link: http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly

The builds in there have version number 1.1a1pre, but if you look at the install.rdf, it is not for Shredder nightly.  Those builds don't seem to be targeted at anything, so I'm thinking they either should match comm-central or be removed.  That is what I installed that gave me grief.
You need to log in before you can comment on or make changes to this bug.