Last Comment Bug 683945 - crash [@ PL_DHashTableOperate | nsScriptError::InitWithWindowID ]
: crash [@ PL_DHashTableOperate | nsScriptError::InitWithWindowID ]
Status: RESOLVED FIXED
[mobile-crash]
: crash, topcrash
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: 8 Branch
: ARM Android
: -- normal (vote)
: mozilla9
Assigned To: Josh Matthews [:jdm] (away until 9/3)
:
Mentors:
: 684868 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-01 10:15 PDT by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2011-09-07 07:49 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid using a deleted hashtable for finding window IDs. (2.17 KB, patch)
2011-09-03 16:41 PDT, Josh Matthews [:jdm] (away until 9/3)
no flags Details | Diff | Splinter Review
Avoid using a deleted hashtable for finding window IDs. (1.23 KB, patch)
2011-09-03 16:43 PDT, Josh Matthews [:jdm] (away until 9/3)
jst: review+
Details | Diff | Splinter Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-09-01 10:15:06 PDT
This bug was filed from the Socorro interface and is 
report bp-b1622a2f-dbd9-436e-ae5d-06a1c2110901 .
============================================================= Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:615
1 	libxul.so 	nsScriptError::InitWithWindowID 	nsTHashtable.h:171
2 	libxul.so 	XPCConvert::JSErrorToXPCException 	nsTSubstring.h:113
3 	libxul.so 	XPCConvert::JSValToXPCException 	js/src/xpconnect/src/xpcconvert.cpp:1664
4 	libxul.so 	nsXPCWrappedJSClass::CheckForException 	nsCOMPtr.h:790
5 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1695
6 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:586
7 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:133
8 	libxul.so 	libxul.so@0x93e088 	
9 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
10 		@0x0 	
11 	libxul.so 	nsTimerEvent::Run 	nsAutoPtr.h:907
12 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
13 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
14 	libxul.so 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:493
15 	libxul.so 	nsHtml5ParserThreadTerminator::Observe 	nsCOMPtr.h:653
16 	libxul.so 	nsObserverList::NotifyObservers 	nsVoidArray.h:63
17 	libxul.so 	nsObserverService::NotifyObservers 	nsTHashtable.h:170
18 	libxul.so 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:606
19 	libxul.so 	NS_ShutdownXPCOM_P 	xpcom/build/nsXPComInit.cpp:559
20 	libxul.so 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1085
21 	libxul.so 	XRE_main 	nsCOMPtr.h:790
22 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
23 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:234
24 	libdvm.so 	libdvm.so@0x10e37 	
25 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x21ae33 	
26 	2 (deleted) 	2 @0x11cc47 	
27 	libdvm.so 	libdvm.so@0x10fff 	
28 	libdvm.so 	libdvm.so@0x3f3ca 	
29 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x117d2 	
30 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:234
31 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x21ae33 	
32 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x21ae33 	
33 	libdvm.so 	libdvm.so@0x9c3f3 	
34 	2 (deleted) 	2 @0x11cc47 	
35 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:234
36 	libdvm.so 	libdvm.so@0x44a98 	
37 	0 (deleted) 	0 @0x41c7 	
38 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0xaef9 	
39 	2 (deleted) 	2 @0x11cc47 	
40 	libdvm.so 	libdvm.so@0x15d9b 	
41 		@0x3fffffff 	
42 	libdvm.so 	libdvm.so@0x9c2df 	
43 	libdvm.so 	libdvm.so@0xa0edf 	
44 	libdvm.so 	libdvm.so@0x1c7ff 	
45 	libdvm.so 	libdvm.so@0x1c783 	
46 	libdvm.so 	libdvm.so@0x1b69f 	
47 	core.odex 	core.odex@0xe3f6f 	
48 	2 (deleted) 	2 @0x25a4d7 	
49 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x21b2ab 	
50 	libdvm.so 	libdvm.so@0x15ae3 	
51 	libdvm.so 	libdvm.so@0x15b1f 	
52 	libdvm.so 	libdvm.so@0x15a07 	
53 	libdvm.so 	libdvm.so@0x15a2f 	
54 	libdvm.so 	libdvm.so@0x15a5f 	
55 	libdvm.so 	libdvm.so@0x15a83 	
56 	libdvm.so 	libdvm.so@0x7560c 	
57 	core.odex 	core.odex@0xd5d5f 	
58 	core.odex 	core.odex@0xd5d5f 	
59 	core.odex 	core.odex@0xf46f3

More Reports: https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-09-01%2007%3A00%3A00&signature=PL_DHashTableOperate%20%7C%20nsScriptError%3A%3AInitWithWindowID&version=Fennec%3A9.0a1
Comment 1 nemo 2011-09-03 07:55:49 PDT
This is my second time experiencing this crash in a few days.  Both times it was after restarting to apply changes.  The first time when switching themes back and forth to test bug #682835, and most recently when restarting to turn off mobile tools.  Not consistently reproducible, and was not on any special page.  I only had 1 or 2 tabs.
Comment 2 Josh Matthews [:jdm] (away until 9/3) 2011-09-03 16:41:25 PDT
Created attachment 558109 [details] [diff] [review]
Avoid using a deleted hashtable for finding window IDs.
Comment 3 Josh Matthews [:jdm] (away until 9/3) 2011-09-03 16:43:27 PDT
Created attachment 558110 [details] [diff] [review]
Avoid using a deleted hashtable for finding window IDs.
Comment 4 Josh Matthews [:jdm] (away until 9/3) 2011-09-06 08:46:43 PDT
*** Bug 684868 has been marked as a duplicate of this bug. ***
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2011-09-06 11:31:37 PDT
Comment on attachment 558110 [details] [diff] [review]
Avoid using a deleted hashtable for finding window IDs.

r=jst
Comment 6 Josh Matthews [:jdm] (away until 9/3) 2011-09-06 11:41:19 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/41d43c3a7286

Note You need to log in before you can comment on or make changes to this bug.