Bookmarks button still shows when turned off in preferences

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Bookmarks & History
P2
normal
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: db, Assigned: Samir Gehani)

Tracking

({regression})

Trunk
mozilla0.9
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
On a new profile in the Preferences->Navigator, there is a toolbar section with

Bookmark
Go
Home
Print
Search

where the last three is initially selected. Still, in the browser the bookmarks
are activated even if it's not checked here in the prefs. To deactivate
bookmarks one have to select bookmark, press OK, no change. Go back, unselect
bookmark, press OK. And now it's gone in the browser

The same thing in the Preferences->Navigator->Bookmarks prefs page. The "Always
ask me ..." setting is active in the browser but not checked. Also, when I open
this prefs page i get this:

chrome://communicator/content/bookmarks/pref-bookmarks.xul line 52: rName has no
properties


There seems to be some error in the model-view handling that one usually uses
for these things. It seems like the prefs-window have one model that is not
updated from the browser model. Ar least they down match.

This is on linix, build 2001020908

Comment 1

17 years ago
Ben's fault, I think.
Assignee: matt → ben
Component: Preferences → Bookmarks
QA Contact: sairuh → claudius
Summary: Preferences dialog and reality (browser) don't match → Bookmarks button still shows when turned off in preferences
I see this in the 2001-02-11-06 build on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
*** Bug 68760 has been marked as a duplicate of this bug. ***
triaging per ben's request
Keywords: nsbeta1, regression
Target Milestone: --- → mozilla0.9
*** Bug 69553 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Yeah I saw this too.

Workaround:

Open prefs,  click Bookmarks checkbox,  Click OK in prefs

Now you can either go back and uncheck it again, this will result in the
bookmarks folder disappearing from the toolbar. Or you can have it there.

Reporter, if you start from a new profile - does this occur for you then? I
guess this bug might have something to do with a new pref which is initially
default set to true...
OS: Linux → All

Comment 7

17 years ago
Mass moving most of mozilla0.9 bugs to mozilla0.8.1
Target Milestone: mozilla0.9 → mozilla0.8.1

Comment 9

17 years ago
I see this happening every time I install a nightly.  To install, I completly
rid my computer of Mozilla removing c:\program files\mozilla.org\*;
c:\winnt\moz*; c:\winnt\profiles\myprofile\application data\mozilla.

WinNT 4.0 SP5
IBM ThinkPad 600e
224MB RAM
6GB HD (200MB free)

Comment 10

17 years ago
No need to touch all.js, just add the hidden attribute to bookmarks-button, per
irc. r=jag with that change.

Comment 11

17 years ago
*** Bug 71353 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 70815 has been marked as a duplicate of this bug. ***
Fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
*** Bug 72140 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
almost fixed. with a new profile the default is to have this button
on(and it is) but the pref is unchecked. Checking the pref correctly results
in the button staying visible, it's just that the initial conditions
don't match.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

17 years ago
that was with the 2001032908 builds by the way, and this is actually still
exactly as the reporter originally described it.

Comment 17

17 years ago
I see what happened here. In the patch, the bookmarks button was hidden by
default (hidden="true"), but Ben checked in hidden="false". That change however
requires all.js to be updated too, which wasn't needed when the button was
hidden by default.

Either navigator.xul needs to be fixed to have the button hidden by default, or
all.js needs to be fixed to mark the button as shown.

Comment 18

17 years ago
nav triage team:

Marking nsbeta1+, mozilla0.9, reassigning to pchen
Assignee: ben → pchen
Status: REOPENED → NEW
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: mozilla0.8.1 → mozilla0.9

Comment 19

17 years ago
Samir is going to take some of my bugs. Yeah! Reassigning to Samir
Assignee: pchen → sgehani
(Assignee)

Comment 20

17 years ago
Created attachment 31091 [details] [diff] [review]
Sync all.js to reflect bookmarks is on by default (2nd half of ben's original patch essentially).
(Assignee)

Comment 21

17 years ago
pchen, please r.
alecf, please sr.

Thanks!
Status: NEW → ASSIGNED

Comment 22

17 years ago
r=jag

Comment 23

17 years ago
sr=alecf
(Assignee)

Comment 24

17 years ago
Fix checkec in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 25

17 years ago
*** Bug 75818 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
VERIFIED Fixed on 2001051508 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.