[Stub Installer] New copy

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: lforrest, Assigned: matej)

Tracking

Details

(Reporter)

Description

7 years ago
As we just discussed, new copy is needed through the stub installer processes mockup documented here: https://bug675970.bugzilla.mozilla.org/attachment.cgi?id=551607

Specifically related to product features. Please have at it based on what we discussed during our kickoff call. 

Timing: Looking for final design + copy assets to be ready by 9/9.

Comment 1

7 years ago
I wasn't in the call, but how can we weave in the brand message here? I think that's extremely important.
(Assignee)

Comment 2

7 years ago
Another thing just occurred to me as well: People will get this after visiting mozilla.org/firefox and clicking Download. That page says "Made to make the Web a better place" along with "a new look, super speed, even more awesomeness."

We were talking about a slightly different version of that on the call, but I now wonder if it makes more sense to either keep the same language on the installer or change it completely so people are getting a new message. If it's close but a little different, I'm worried it's going to look inconsistent or like a mistake.

Personally I'd vote to change the copy here. They've already seen the above on the landing page. The installer is an opportunity to give them more information rather than just rehashing the same.

Sorry I'm just thinking of this now. What do others think?

Comment 3

7 years ago
Good thoughts. The copy bits on the site and the installer should definitely be complimentary to each other...it's fine to repeat the same key points as needed, but I agree that we can also use this as an opportunity to tell another part of the story. Now that they're in a layer deeper than the homepage, we can flesh things out more.

In other words, we should be thinking of this as one part of a larger narrative rather than an individual placement that's functioning on it's own.
(Assignee)

Comment 4

7 years ago
John, just to get you in the loop, we were talking about making the feature headings about speed, look/UI and security/privacy. Do you think we should keep the same three points as the landing page (look, speed, awesomeness) and then drill down further from there?

Laura mentioned there's some new Firefox messaging forthcoming. I imagine that will affect the download page as well, so we can update both when that gets settled.

Also, regarding the brand message, I think this would be a good place to integrate "Firefox answers to no one but you," if possible. Or were you thinking of something else?

Comment 5

7 years ago
It seems like we should get the new Firefox messaging first, and then decide on the content here. Otherwise it runs the risk of being outdated before we even get going.

Re: brand message, the "answers to no one but you" line could be part of it for sure, but I'd also like to go a bit deeper than just that...something that explains our non-profit nature and what it means (sort of like the snippet you've been working on).

Laura, what would the update process for this be like if we wanted to change it over time? I assume l10n will be a big component, so it's probably something we won't want to change too often, right?
(In reply to John Slater from comment #5)
> It seems like we should get the new Firefox messaging first, and then decide
> on the content here. Otherwise it runs the risk of being outdated before we
> even get going.

My concern is that the developer will start work on this in Mid september and we wont have signed off messaging or positioning for a while yet. I think its more important to get this done now and make edits when we're set with the new messaging, as opposed to losing even more downloads while we wait for that to happen. 

> 
> Re: brand message, the "answers to no one but you" line could be part of it
> for sure, but I'd also like to go a bit deeper than just that...something
> that explains our non-profit nature and what it means (sort of like the
> snippet you've been working on).
I'm a bit on the fence with the brand message--not sure how it could fit within the UI we've seen.  Do you have an idea of where it should go?


> 
> Laura, what would the update process for this be like if we wanted to change
> it over time? I assume l10n will be a big component, so it's probably
> something we won't want to change too often, right?
This is true--this is something we likely don't want to change often. But the strings are few and as long as we flag them with 6 weeks for l0n to work on this, I think we're ok.
(Reporter)

Comment 7

7 years ago
Note here that we're pretty limited on the space we have for messaging, and that while at this point within the installer experience we do have time to talk directly to the user during the download process, it's important to be succinct. 

Take a look at: https://bug675970.bugzilla.mozilla.org/attachment.cgi?id=551607
Blocks: 675970
(Assignee)

Comment 8

7 years ago
I can write a few options for a brand line and we can see if it fits as we move forward (maybe we can move the three points down and slot it in above them?).

As for the three points themselves, I want to make sure we're on the same page. As I see it, we have two options:

1) Make them the same as the download page: new look, super speed, more awesomeness

2) Make them echo the download page, but write them more like category headings: performance, interface, security

Either way, we can drill down from there and get into more of what each one of those means. I think I'll try to write those as a combination of features and benefits (so for interface/look, we can have "app tabs" but also stuff like "stays out of your way).

Which of the two above approaches do you guys prefer?
Hi all--

John and I connected today and I think I'm on the same page with John around 
the mix between product marketing and branding messages. 

basically, it sounds like we want the mission to help frame how we talk about features. People have already downloaded at this point, so we want to focus on the "what makes us different" and how that affects how we work on general features like security, performance, ui, speed, etc. John, do you have more to add?

I'm also working on finding out if Friday is our real deadline. I don't think it really is, fwiw. I would like to find some time next week to discuss and throw some ideas out while we're in person.

Comment 10

7 years ago
Thanks Laura. I agree with your take in comment #9.

To elaborate a bit more, we know that not all that many people understand our non-profit/mission-oriented nature, but that when people do know about that they're much more inclined to download and use Firefox. Given that they already will have downloaded, this seems like an excellent opportunity to make that point as part of their first impression with the product.

Assuming we can get an extension past Friday, I'd definitely like to set aside some time next week to brainstorm and plot out the copy flow. I'd also like to look at this more holistically...really examine the entire process from the homepage to the post-download TY page to the installer to the first run page and make sure the experience feels right and is carefully thought through at every step.

I'm super excited about this...I've thought for a long time that the product itself is the best place to communicate about who we are, and this is a great opportunity to do so without being too obtrusive or pushy.
(Assignee)

Comment 11

7 years ago
Thanks guys. Very excited about the potential here. Please let me know as soon as you do whether we need copy for tomorrow or not. I look forward to chatting more about this next week.
Just got word that the contractor won't be able to work on this project, so the deadline is (thankfully!) no longer tomorrow. I'll catch up with rob to see whats more doable, but lets plan on meeting next week. LoFo--want to set up some time?

I think it would also be good to get the copy solid for end of the month, which I think sounds fair and allows us to have everything ready as we get a new contractor sorted out.

Comment 13

7 years ago
Reviewing the mockup:

https://bug675970.bugzilla.mozilla.org/attachment.cgi?id=551607

I think it works extremely well for product copy.  I agree that it is highly desirable to acquaint the user with Mozilla here, but I see a few gaps:

-no mention of "Mozilla Firefox", just "Firefox" (is this a policy?)

-describing Mozilla, the non-profit ought to have some different brand elements to Firefox, if mozilla.org's branding is reflective of Mozilla's identity, I thikn we should use that, as some form of "take over" of the 3rd window in rotation with 2 screens of Firefox features.

Laura M: if we have a trichotomy of Fx positioning concepts that we're very happy with, I think we'd have difficulty identifying 2 screens of feature content, agree?
(Reporter)

Comment 14

7 years ago
A update on this: Matej is working on various copy versions and will update the final, or close to final, version here when it's ready. 

We're hoping to do that sometime this week.
(Assignee)

Comment 15

7 years ago
Here's the copy we've come up with for the installer. There are two versions, since we don't think the last panel of the "regular" version will be easily l10n-able. Next step is to get it mocked up (adding Sean) and share it a bit wider for more feedback.


REGULAR VERSION

HEADLINE
Welcome to Mozilla Firefox — Made by a non-profit to make browsing better for you. Click to install.

PANEL 1
You’re about to enjoy the latest performance, customization and security features so you're always in control online.

PANEL 2
And you’re joining a global community of users, contributors and developers working to make the best browser in the world. (Thanks, by the way.)

PANEL 3
You even get a haiku:
Made with a mission
Answers to no one but you
For a better Web


L10N VERSION

HEADLINE
Welcome to Mozilla Firefox — Made by a non-profit to make browsing better for you. Click to install.

PANEL 1
You’re about to enjoy the latest performance, customization and security features so you're always in control online.

PANEL 2
That’s because Firefox is made with a mission to answer only to you, with no other interests, concerns or motives.

PANEL 3
And you’re joining a global community of users, contributors and developers working to make the best browser in the world. (Thanks, by the way.)

Comment 16

7 years ago
Thanks for providing a non-haiku version.

The language is pretty dense still.

Do we know yet if this copy will be shipped as part of the browser or happen somewhere on the web? Not sure how much we can ship two different sets of copy in either setup.
(Reporter)

Updated

7 years ago
Blocks: 690126
(Reporter)

Comment 17

7 years ago
(In reply to Axel Hecht [:Pike] from comment #16)
> Thanks for providing a non-haiku version.
> 
> The language is pretty dense still.
> 
> Do we know yet if this copy will be shipped as part of the browser or happen
> somewhere on the web? Not sure how much we can ship two different sets of
> copy in either setup.

Thanks for the flag! Intent is to have localizers pick which version they see fit (Haiku version or or not). The open question remains around if nsis installer setup can do two different copies, or in general the best way to localize this.
(In reply to Axel Hecht [:Pike] from comment #16)
> Thanks for providing a non-haiku version.
> 
> The language is pretty dense still.
> 
> Do we know yet if this copy will be shipped as part of the browser or happen
> somewhere on the web? Not sure how much we can ship two different sets of
> copy in either setup.
In the installer. Could we just add an l10n note with the non haiku text and send an email to the l10n email list regarding this?

Comment 19

7 years ago
Copied from email:

A side thought: how suitable is the Haiku for en-US users outside of the US? Excluding the US, en-US still has an ADU share of 25%, Indonesia, India etc being big. Or, to slice the numbers the other way around, 48% of en-US are actually in the US.
(Reporter)

Comment 20

7 years ago
Update on this: We're currently still in the process of iterating through copy versions. However, the overall structure and graphics of the stub-installer should remain similar to what is seen here: http://cl.ly/1X2x2V0a3a062u472U0t/o so I hope this is not currently a blocker. 

Axel raises a valid point in comment 19. Axel - can you put me in touch with l10n or other community members from Indonesia and India to talk this through? I can also ask Mary.

Comment 21

7 years ago
I think that remo might be a richer resource for points of contact in the region. https://wiki.mozilla.org/Special:SearchByProperty/Country/India is pretty rich on people, https://wiki.mozilla.org/Special:SearchByProperty/Country/Indonesia, too.
I know I'm late, but this is going to be quite a pain to localize for languages that use a formal/impersonal style, changing it every 6 weeks is even worse. 

Also a question: is the installer going to be skype-like (minimum installer, download files from Internet)?
(Assignee)

Comment 23

7 years ago
(In reply to flod (Francesco Lodolo) from comment #22)
> I know I'm late, but this is going to be quite a pain to localize for
> languages that use a formal/impersonal style, changing it every 6 weeks is
> even worse. 

As far as I understand it, we won't be updating this every 6 weeks. The idea is to make the messaging general enough that we don't have to make changes for a while.
(Reporter)

Comment 24

7 years ago
(In reply to Matej Novak [:matej] from comment #23)
> (In reply to flod (Francesco Lodolo) from comment #22)
> > I know I'm late, but this is going to be quite a pain to localize for
> > languages that use a formal/impersonal style, changing it every 6 weeks is
> > even worse. 
> 
> As far as I understand it, we won't be updating this every 6 weeks. The idea
> is to make the messaging general enough that we don't have to make changes
> for a while.

Correct - no need to update every 6 weeks.
(Reporter)

Comment 25

7 years ago
Here's the final copy. We would like to use the Haiku version in en-US, and the second non-haiku version in all other locales:

STUB INSTALLER (en-US Version)

HEADLINE
Thanks for choosing Mozilla Firefox. We’re not just designed to be different, we’re different by design. Click to install.

PANEL 1
You’re about to enjoy the very latest in speed, flexibility and security so you're always in control.

PANEL 2
And you’re joining a global community of users, contributors and developers working to make the best browser in the world.

PANEL 3
You even get a haiku:
Proudly non-profit
Free to innovate for you
And a better Web

STUB INSTALLER (l10n version)

HEADLINE
Thanks for choosing Mozilla Firefox, the browser that chooses you above everything else.

PANEL 1
You’re about to enjoy the very latest in speed, flexibility and security so you're always in control.

PANEL 2
That’s because Firefox is made by a non-profit to make browsing and the Web better for you.

PANEL 3
You’re also joining a global community of users, contributors and developers working to make the best browser in the world.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

6 years ago
Reopening to tweak messaging for Nightly, Aurora and Beta. Does anyone have any additional direction about what can stay, what needs to go and what we should be saying for those channels before I dive in?

Is this the best place to work on this or should I open a new bug?

Also, how much time do we have? According to this morning's meeting, the installer has landed already.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The new artwork could just be attached to bug 795654.

Comment 28

6 years ago
Matej, my advice re: messaging would be to be to pull from the very broad direction described on http://www.mozilla.org/en-US/styleguide/identity/firefox/channels/. 

This isn't the place to get too specific about features, performance details, etc so just hitting the high points of what Aurora and Nightly are all about, and how users can help, would be great.
Please note that at this time we just need new artwork... if you decide to use different text then I believe that will be the first time that we have used different text outside of a web page, etc. based on channel and it will need to be a new / separate bug for implementation since we don't have support for that.
Couple more notes... the format of the images must be in bitmap format and the image with the name must use the same number of colors and same background color as the one in the zip attachment in bug 795654. Also, the images that fill the UI must be the same size as the images in the zip attachment in bug 795654.
(Assignee)

Comment 31

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #29)
> Please note that at this time we just need new artwork... if you decide to
> use different text then I believe that will be the first time that we have
> used different text outside of a web page, etc. based on channel and it will
> need to be a new / separate bug for implementation since we don't have
> support for that.

Back when I created the copy for this, I didn't realize we'd be using the stub installer for the other channels as well, but looking at it now, the copy doesn't really fit for all of them.

How difficult/realistic will it be to change the copy by channel? (Not sure if it's the same thing, but we do currently use different About text for our channels.)

At the very least, we'll have to change the opening line:

Thanks for choosing Mozilla Firefox.

Thanks for choosing Firefox Beta.

Thanks for choosing Firefox Aurora.

Thanks for choosing Firefox Nightly.
(In reply to Matej Novak [:matej] from comment #31)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #29)
> > Please note that at this time we just need new artwork... if you decide to
> > use different text then I believe that will be the first time that we have
> > used different text outside of a web page, etc. based on channel and it will
> > need to be a new / separate bug for implementation since we don't have
> > support for that.
> 
> Back when I created the copy for this, I didn't realize we'd be using the
> stub installer for the other channels as well, but looking at it now, the
> copy doesn't really fit for all of them.
> 
> How difficult/realistic will it be to change the copy by channel? (Not sure
> if it's the same thing, but we do currently use different About text for our
> channels.)
> 
> At the very least, we'll have to change the opening line:
> 
> Thanks for choosing Mozilla Firefox.
> 
> Thanks for choosing Firefox Beta.
> 
> Thanks for choosing Firefox Aurora.
> 
> Thanks for choosing Firefox Nightly.
Any text where "Firefox" or "Mozilla Firefox" is used we use Nightly or Aurora.

As for how difficult / realistic it will be depends on the change requested. For example, there was concern about the haiku text because we don't one-off l10n but we came up with a one-off way for en-US to have the haiku in the stub installer.

Changes beyond that will need bugs filed. Also, it would be helpful to first get the changes you would like finalized in a Marketing -> Copy bug and then file a Firefox -> Installer bug that depends on that bug.
(Assignee)

Comment 33

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #32)
>
> Any text where "Firefox" or "Mozilla Firefox" is used we use Nightly or
> Aurora.

Since this will be the first mention, we have to say the complete name.


> As for how difficult / realistic it will be depends on the change requested.
> For example, there was concern about the haiku text because we don't one-off
> l10n but we came up with a one-off way for en-US to have the haiku in the
> stub installer.
> 
> Changes beyond that will need bugs filed. Also, it would be helpful to first
> get the changes you would like finalized in a Marketing -> Copy bug and then
> file a Firefox -> Installer bug that depends on that bug.

I'll work on some copy tomorrow and post it to the bug, but it looks like only the first screen will change.
(In reply to Matej Novak [:matej] from comment #33)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #32)
> >
> > Any text where "Firefox" or "Mozilla Firefox" is used we use Nightly or
> > Aurora.
> 
> Since this will be the first mention, we have to say the complete name.
Sounds good and I'm fine with changes from the existing format we have been using for years. Please write up the changes and after that is done please file a Firefox -> Installer bug with either the write up or a pointer to the write up.

> 
> 
> > As for how difficult / realistic it will be depends on the change requested.
> > For example, there was concern about the haiku text because we don't one-off
> > l10n but we came up with a one-off way for en-US to have the haiku in the
> > stub installer.
> > 
> > Changes beyond that will need bugs filed. Also, it would be helpful to first
> > get the changes you would like finalized in a Marketing -> Copy bug and then
> > file a Firefox -> Installer bug that depends on that bug.
> 
> I'll work on some copy tomorrow and post it to the bug, but it looks like
> only the first screen will change.
okay
(Assignee)

Comment 35

6 years ago
Hi all,

After thinking about this some more, I'd like to change more than just the first screen. The audience for each channel is quite different, as is the way we talk about it. For that reason, I also don't think the haiku fits anywhere but GA (so we don't need en-US and l10n versions for the other channels). I mostly grabbed existing copy and tweaked it to fit the format here. The only line that resonated for each channel was the one about the "global community."

And Robert, you were right about not having to use the full names here. I forgot that the wordmark precedes the text, so that's actually the first mention.

It was all getting a little long, so I put the versions into an etherpad for your perusal:

https://etherpad.mozilla.org/StubInstallerCopy
(Assignee)

Comment 36

6 years ago
Another consideration here is going to be l10n, so we should try to get the copy finalized asap so we can start that process. Please let me know if you have any comments on the etherpad.

Comment 37

6 years ago
The text should be more or less easy to translate, with two caveats:

Thanks for choosing Mozilla Firefox, the browser that chooses you above everything else. Click to install.

This one can use a note how freely it should be translated/localized. If we have a close race between alternatives, one or two might be good to mention, to pick the one that suits the locale best.

There's also been in a question in the newsgroup about the "Click to install." Does that help or confuse? I.e, either you know what to click, and then you know that you should click. Or you don't, and then all hell breaks loose by having that text on something that's no click target?
Perhaps "Click Install to continue." or "Click the Install button below to continue."
(Assignee)

Comment 39

6 years ago
(In reply to Axel Hecht [:Pike] from comment #37)
> The text should be more or less easy to translate, with two caveats:
> 
> Thanks for choosing Mozilla Firefox, the browser that chooses you above
> everything else. Click to install.
> 
> This one can use a note how freely it should be translated/localized. If we
> have a close race between alternatives, one or two might be good to mention,
> to pick the one that suits the locale best.

As far as I'm concerned, this should be translated as freely as is necessary to convey a similar meaning. In this case, the focus should be on the idea of Firefox putting the user first and less on the wordplay around the word "choose" (that would be nice, but the message is more important).

> There's also been in a question in the newsgroup about the "Click to
> install." Does that help or confuse? I.e, either you know what to click, and
> then you know that you should click. Or you don't, and then all hell breaks
> loose by having that text on something that's no click target?

We could clarify this by saying "Click below to install."
(Assignee)

Comment 40

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #38)
> Perhaps "Click Install to continue." or "Click the Install button below to
> continue."

Of these I prefer "Click Install to continue," but I think I like "Click below to install" since it tells users where to click, but doesn't add a lot of words.
We could also put this on its own line as we do in the full installer. Installer's often do this so people that never bother reading the text know what to do to get on with installing an application. I think this would alleviate the concern regarding the additional text. Perhaps "Click Install below to continue" which is one additional word.
(Assignee)

Comment 42

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #41)
> We could also put this on its own line as we do in the full installer.
> Installer's often do this so people that never bother reading the text know
> what to do to get on with installing an application. I think this would
> alleviate the concern regarding the additional text. Perhaps "Click Install
> below to continue" which is one additional word.

I'm OK with positioning the text below, if that works, but I find that wording a little clunky. What do other people think?
(Assignee)

Comment 43

6 years ago
One more thing that just occurred to me: The icons that go with each screen were designed to accompany the original text, but they may not match up with the new copy for each channel (even in the l10n version, the pencil doesn't really go with the last screen since we're not using the haiku there).

Here's what they look like now: http://cl.ly/image/2N0X1J3z3l1U/o

John, should I file a bug to get these updated?

Comment 44

6 years ago
(In reply to Matej Novak [:matej] from comment #43)
> John, should I file a bug to get these updated?

Yes please.
Once you figure out the copy for each channel please file a new Firefox -> Installer bug to implement it. If the new images are ready at the same time that would be a good thing (we'll need RTL images in some cases as I have mentioned before). I can do implement different copy for each channel as a one off though this work will take a back seat to other higher priority work. Also, it isn't something our l10n system supports beyond changing the brand full name and brand short name which the stub installer / installer has always supported and is already implemented for the stub installer.
(Reporter)

Comment 46

6 years ago
Update: Let's limit the scope to get this done. For each channel please use the same copy and graphics that have already been created. 

Robert: If you can change the brand name string where it makes sense, then go ahead. But let's consider all copy for this round as complete.   

We will revisit adding more custom copy in V2.
(In reply to Laura Forrest from comment #46)
> Update: Let's limit the scope to get this done. For each channel please use
> the same copy and graphics that have already been created. 
> 
> Robert: If you can change the brand name string where it makes sense, then
> go ahead. But let's consider all copy for this round as complete.   
Already done.

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.